Text Based RL9 installation via kickstart file

Hi Team ,
I am setting up the RL9 as cobbler based installation via kickstart file. I have integrate RL9 with cobbler, Cobbler is booting up via PXE properly from profile created but some how while installing OS its getting terminate and issue is showing with module “install”

I have tried “inst.install” that also not help here , Could some one please help me to fix this

kickstart file :

# Partition clearing information
clearpart --all --initlabel
# Use text mode install
# Firewall configuration
firewall --disabled
# Run the Setup Agent on first boot
firstboot --disable
# System keyboard
keyboard us
# System language
lang en_US
# Use network installation
url --url=$tree
# If any cobbler repo definitions were referenced in the kickstart profile, include them here.
# Network information
# Reboot after installation

#Root password
rootpw --iscrypted $default_password_crypted
#rootpw pass@123
# SELinux configuration
selinux --disabled
# Do not configure the X Window System
# System timezone
timezone --utc UTC
# Install OS instead of upgrade
# Clear the Master Boot Record
# Allow anaconda to partition the system as needed


I think **install** is not a valid kickstart syntax. Remove the * sign and use only install and try.

Thanks Prasad , it was BOLD while updating in forum here so it is showing in ** install **
in ks file it is install only , I have tried with same its not helping to fix

update to supported syntax…


1 Like

Once the error occurs switch to other TTYs (ctrl+alt+F1/F2/F3, don’t remember which). One of the TTY will show verbose output of the activity. That might give a hint to the issue.

Thank you !!
Issue is still not fixed , I check logs but its only mentioning about install keyword which looks like deprecated and not allowing custom partition as well

according to the anaconda-ks.cfg on my rocky 8 system the syntax for keyboard is

# Keyboard layouts
keyboard --xlayouts=‘gb’
# System language
lang en_GB.UTF-8

for my UK system.

worth a try.

the anaconda-ks.cfg of an interactive install is always a good place to look for syntax examples.
regards peter

I have updated this as per US settings , but still not help

im not sure this is a kickstart file error, and am starting to think its an incomplete kickstart server setup.

its been a while since I last built a kickstart server from scratch, so forgive me if im missing stuff.

but along with the syslinux bit you also need an initrd if I remember rightly (part of the bootp setup).

A good place to start is PXELINUX - Syslinux Wiki

and I think your setup is stalling when trying to mount initrd.

would have been nice to see the lines above initqueue

regards peter

Thanks Peter ,

The Cobble kickstart I am using is working well with other OS up to CENTOS 7. We are tying to integrate Rocky Linux 9 first time with our existing Kickstart Setup.

I have updated some deprecated keywords with inst., But not sure still I am facing issue for stage2 and repo keywords

OK well the last kickstart i did was Centos 7, so maybe somthing has changed in 8 or 9 that im not aware of and I feel your pain as i remember making our custom kickstart server work with rhel6 when it was written for 5.
anything in this document stick out in the kickstart file that cobbler creates.

sometimes its easier to create a really basic tftpboot/bootp server and http server with a single kickstart file in it tied to your mac address and just use that to get to the bottom of the issue as cobbler probably has loads of bits that build the final config, and finding which one is causing your problem when you dont know what the problem is is difficult. if you know which part of the kickstart is wrong then its easy to grep for what builds that part in the cobbler scripts and then add an if [$RHEL = 9]then …
also grab the anaconder.cfg from an interactive rocky9 build as a starting point.

regards peter

Hi Team ,
This is fixed now , I am able to boot VM/Physical via cobbler kickstart file
changes updated :

  1. keyboard --vckeymap=gb --xlayouts=‘gb’
  2. Disk partitioning information

#autopart --type=lvm
part /boot --fstype=“xfs” --ondisk=sda --size=1024 --label=boot --asprimary --fsoptions=“rw,nodev,noexec,nosuid”
part pv.01 --fstype=“lvmpv” --ondisk=sda --size=31743
volgroup vg_os pv.01
logvol /tmp --fstype=“xfs” --size=1024 --label=“lv_tmp” --name=lv_tmp --vgname=vg_os --fsoptions=“rw,nodev,noexec,nosuid”
logvol / --fstype=“xfs” --size=30716 --label=“lv_root” --name=lv_root --vgname=vg_os
3. update /var/lib/tftpboot/pxelinux.cfg/kickstart-Mac-Address
append initrd=/images/rl9-x86_64/initrd.img ksdevice=bootif inst.kssendmac inst.ks=https://your-cobbler-kickstrat-autoinstall-profile
4. These changes help me to install OS via Rocky 9 cobbler server

Thank you so much for all your suggestions