Starting Openvpn

I have installed Openvpn from EPEL and, once again, the way to start it appears to have changed.

I have a config file in /etc/openvpn/openvpn.conf. The Openvpn service appears to be masked, but unmasking it doesn’t help:

systemctl unmask openvpn@server

systemctl enable openvpn@server

Failed to enable unit: Unit file /usr/lib/systemd/system/openvpn@.service is masked.

I unmasked it, so why doesn’t it start?

It should be enough to just do:

systemctl unmask openvpn

you don’t need the @server bit.

systemctl unmask openvpn

Unit openvpn.service does not exist, proceeding anyway.

I don’t understand the point of building a package that is only installed when needed and setting the unit to be masked.

Obviously whoever packaged it had a reason for it. It’s not the first time it has happened. I’ve seen other services masked by default.

Perhaps I need to write my own unit file and completely ignore the one provided in the EPEL package?

I finally figured this out. The information was in a README file:

I followed the instructions there and it worked. No masks involved.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.