Migrated from CentOS but cannot find the telnetd after adding telnet-server rpm

Hi,

I migrated from CentOS 7, but I cannot find the telnetd after installing telnet-server rpm on Rocky 9. Am I missing something. Thanks in advance, Marc.

Is there a reason for running telnetd especially since telnet is insecure. Usually remote connections to a server would be done over SSH instead - far more secure, encrypted. Telnet isn’t.

The telnet-server package has the following files:

root@rocky9 ~]# dnf repoquery -l telnet-server

/usr/lib/.build-id
/usr/lib/.build-id/39
/usr/lib/.build-id/39/ead747a97485726d76317825cd6785a296d8dc
/usr/lib/systemd/system/telnet.socket
/usr/lib/systemd/system/telnet@.service
/usr/sbin/in.telnetd
/usr/share/man/man5/issue.net.5.gz
/usr/share/man/man8/in.telnetd.8.gz
/usr/share/man/man8/telnetd.8.gz

then you would just do systemctl start telnet to get the server running. And use systemctl enable telnet to ensure it’s running on each server reboot.

I have old devices that use only telnet to access the server’s app inside the network and from site VPN connections.

When I ran the command to start the telnet service I got the following errors:


[root@rockytst ~]# systemctl start telnet
Failed to start telnet.service: Unit telnet.service not found.

[root@rockytst ~]# systemctl enable telnet
Failed to enable unit: Unit file telnet.service does not exist.

The above failures gave a clue on extra steps to be done. So, I ran the following:

$ sudo systemctl enable telnet.socket

to startup the service on servier bootup/startup. and,

$ sudo systemctl start telnet.socket

to manually start the telnet service 

to test,

$ telnet localhost
Trying ::1…
Connected to localhost.
Escape character is ‘^]’.

Kernel 5.14.0-70.13.1.el9_0.x86_64 on an x86_64
samco login:

Thanks for you help.