Ssd host boot fails after upgrade to latest Rocky 9

I installed a minimal install of Rocky 9.1 on a slightly older Dell Optiplex 7010 with a KingFast ssd. This machine was happily running Windows 10. A minimal install of 9.1 seemed fine. When I update, there are ~700 new packages and a new kernel. When I reboot, choosing either the old or new kernel (or rescue mode), the boot does find the KingFast. I see the boot halt at “A start job is running for /dev/mapper/rl-home” which times out after about a minute and I’m dropped into rescue mode. When I scroll through the journal, I see several things (virtualization and TCM are disabled in the bios, CONFIG_IMA_DISABLE_HTABLE is disabled) but the problem seems to be that the ssd is not in the devices file (it’s filtered out):

I’m not super technical. I’m comfortable at the command line, but I have little knowledge of LVM. I don’t know how to get the logs off that machine in rescue mode so I’m limited to screenshots.

I have found people with similar problems, but I don’t understand them. This recommends “lvm voodoo”: Install Rocky Linux 9.1 successfully but the clone or import is not work -

And my problem seems specific to the KingFast drive not being found. If I do: lvmdevices --adddev /dev/sd2 I’m told that the device is not found.

I’m not sure how to resolve this. I have re-installed a couple times. I could just get a more recent image and try that.

Some posts suggest this is a dracut bug and the work-around is to boot to a working configuration and downgrade dracut. I haven’t tried that because I don’t have a working configuration. I could re-install 9.1 but I’m hoping for a solution that does not break if I upgrade or pin me to an older version of the OS.

I guess this is solved. I installed the latest ISO (9.2) and when partitioning, I selected a standard partition for all partitions and the newly installed system rebooted, including after updating.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.