Samba Server cannot read/write

Hi everyone,

I have set up some new Linux servers with Rocky Linux version 8.9 for OS upgrade from CentOS to Rocky.

There are some problems with Samba server.

All Samba server and client settings are fine because the setting is copied from the old CentOS server.

I can mount the drive from DMZ to internal with Samba. However, when I tried to read or write files Samba server would auto-reboot for no reason. Creating and deleting files is also slow. I have tried to trace the logs but no findings. May I know have everyone faces the same problem and how to solve it?

The content of the smb.conf

[global]
;workgroup = WORKGROUP
;security = user
;map to guest = bad user
;log file = /var/log/samba/log.%m
;max log size = 50
;encrypt passwords = yes
;smb passwd file = /etc/samba/smbpasswd
;load printers = no
;printing = bsd
;printcap name = /dev/null
;disable spoolss=yes
;lanman auth = no
;ntlm auth = yes
;client lanman auth = no
server signing = auto
client signing = auto

--------------------------- Filesystem Options ---------------------------

; follow symlinks = yes
; unix extensions = no
; wide links = yes

#==== Share Definitions ====

;[global]
; workgroup = SAMBA
; security = user
;
; passdb backend = tdbsam
;
; printing = cups
; printcap name = cups
; load printers = yes
; cups options = raw

;[homes]
; comment = Home Directories
; valid users = %S, %D%w%S
; browseable = No
; read only = No
; inherit acls = Yes

;[printers]
; comment = All Printers
; path = /var/tmp
; printable = Yes
; create mask = 0600
; browseable = No

;[print$]
; comment = Printer Drivers
; path = /var/lib/samba/drivers
; write list = @printadmin root
; force group = @printadmin
; create mask = 0664
; directory mask = 0775

[LOG_UAT]
path = /backup.dnas/
browseable = yes
read only = no
force create mode = 0660
force directory mode = 2770
valid users = smbsup01 strongpassword
;client signing = default

If selinux is enabled, then the samba contexts need to be set on /backup.dnas - could be a potential reason as to why it’s not working.

Selinux was set to disabled at the first place

Not sure if this will apply to you or not but we had some issues with 9.3 and 8.9 where we actually had to make sure we had a new BIOS installed as we were crashing a lot. BIOS update worked. Something in 8.9 and 9.3 is looking something our servers did not like.

Do you mean I update the BIOS of Baremetal instead of VM?

Update: better describe my situation.

Selinux is set to disabled.
I can mount the drive from DMZ Samba client VM to internal Samba Server VM. However, when I tried to delete files the Samba server VM would auto-reboot for no reason. Creating files is slow and need to wait for the new command line to poop up. I have tried to trace the logs but no findings.