Rocky Linux after update don't know paths (SOLVED)

Hi people,
After upgrading Rocky Linux cmpletly and restarting. RL doesn’t know the PATH anymore.
I can nomore execute standard linux commands without entering the full path, like “ls”…
I always have to enter /usr/bin/ls

After logging in

/usr/libexec/ line 5: grep: command not found
/usr/libexec/ line 5: grep: command not found
/usr/libexec/ line 5: grep: command not found

I figure out that the file /etc/environment is also empty.

If somebody can tell me how to restore the paths and reset the variables, I’d be thankful.



Can you clarify what you mean by upgraded; from what version to what new version, and how did you upgrade it? Can you also clarify what you mean by “logging in”, do you mean you waited for GDM to appear, and then logged in with a user name on the graphical user interface screen?

I figured out that it was entirey my mistake.
I added something in the path through the /etc/environment file, that should not be the case.

In the #rockylinux lebara chat I got told that the paths are nor defined in that filed.
I deleted the entry and restarted the server and everything worked as normal as before.

Thank you for your help!