Rocky forum JavaScript issue (now resolved)

Last week, around May 11, 12, 13, the Rocky forum was showing as just a black screen in my x64 Seamonkey web browser. I think it was related to JavaScript code used by discourse. Right now, it’s working again, so not sure what happened.

One thing I have noticed, is that the response time of the forum is slower than it used to be back in Jan 2022. The JavaScript used by discourse looks very bloated, but it does provide a lot of features.

I haven’t noticed any issues, has worked perfectly fine for me on Firefox, and hasn’t gotten any slower for me.

When it was broken in Seamonkey last week, it did still work in Firefox, but I think there must have been a change because I could see the JavaScript errors.

The delay I’m seeing is when it loads, I see just black screen for about 1 second, and then the text and icons appear. This aligns with the black screen being on ‘’, but the text and icons coming from ‘discourse’.

If it was working in Firefox, at the same time that there were problems in Seamonkey, I would say that it’s rather the browser that is the problem. Could well be that discourse has issues with Seamonkey and probably works better in browsers that are most likely to be supported like Firefox, Chrome, Opera, etc.

There was a time when Firefox wasn’t in Debian repos and was replaced with Iceweasel. Theoretically this was still Firefox, but it generally didn’t work very well on all sites. However, Firefox worked perfectly fine.

Right now, the forum is working well in the Seamonkey web browser, except for one small thing; trying to format a block of code using the ‘<>’ icon doesn’t work anymore. I tried using back ticks as a workaround, but it only partially worked. Is there any other markup I can try in the text editor window to format a code block?

How many backticks were you using? Normally there should be three. Alternatively you can use these brackets [code] and put the word code in it like I have done. And then to close and finish it with [/code] so as an example:

code here

I’ve had to mark the lines with single backticks, else you wouldn’t see the code lines. Otherwise it looks like this:

code here

Testing a code block

This is line one
This is line two
This is line three

This is back to nomal text.

OK, I didn’t know it needed three backticks, and it seems they must be on their own line. This looks good, I think it’s working.