Rocky 8.10 kickstart installation source error (error setting up software source)

I have kickstart installation source error
Can you help handling this error

here is kickstart file

url --url='https://download.rockylinux.org/pub/rocky/8/BaseOS/x86_64/os/'
repo --name='BaseOS' --baseurl='http://pulp.toastmaker.net/pulp/repos/rocky/8/BaseOS/x86_64/os/'


lang en_US.UTF-8
keyboard us
timezone Asia/Seoul

eula --agreed

auth --useshadow --enablemd5

network --device=ens3 --bootproto=dhcp --activate --onboot yes
network --hostname=rocky810

# Use CDROM installation media
#cdrom

selinux --disabled
firewall --disabled
services --disabled=abrtd,certmonger,cgconfig,cgred,corosync,cpuspeed,cups,dovecot,ip6tables,iptables,kdump,modclusterd,multipathd,mysql-mmm-agent,mysql-proxy,netconsole,nfs,nslcd,oddjobd,psacct,quota_nld,rdisc,restorecond,rpcbind,rpcgssd,rpcidmapd,rpcsvcgssd,saslauthd,smartd,snmptrapd,spamassassin,sssd,vncserver,ypbind,sysstat

# mkpasswd -m sha512
authselect --enableshadow --passalgo=sha512
rootpw --iscrypted $6$mSfIyfr0shKOTD0$/Fzfxrb7icpiI02.AFDnB7.DVN9r7/843JGHF79dhxdkEiAdI8VJs6JST4J0TO6C1O/NWhqATdePtmbgywxeP/

selinux --disabled
firewall --disabled

zerombr
clearpart --all --initlabel

part swap --size 2048 --asprimary
part / --fstype xfs --size 1 --grow --asprimary

bootloader --location=mbr --boot-drive=vda

%end
reboot

I did add code tags to your post, around the file content. Easier to read.


Why do you have “BaseOS” twice (in ‘url’ and as additional ‘repo’)?

I don’t see %packages section, only unmatched %end

1 Like

As you mentioned, I deleted “BaseOS” only remaining url.
But the result is same.

The url directive is supposed to point to a repository that has a .treeinfo file. In this case, BaseOS on our mirrors will have that file and it will automatically include the AppStream repo for you. You should only mention additional repo lines if you need to include other repositories, such as PowerTools. Pulp is also supposed to be able to sync .treeinfo files. So if you synced BaseOS, AppStream should also be synced and there should be no issues afterwards. Ensure you have both BaseOS and AppStream available.

There is not much to go off of with “Error setting up software source”. You need to look at window 3 (log) or 5 (program-log) to get an idea of what the issue actually is.

Thanks! Removing extra BaseOS repo (–baseurl), it skips the error. Thanks for your help