Kickstart installation rocky 9.0 - network installation source isn't added

I’m trying to set up a network rock 9 kickstart installation. Everything works fine but just the “installation source” can’t be automatically set up. “Error setting ip base repository” appears on the “Installation summary”. The field in the menu “installation source” / “Which installation source would you like to use” rests empty. When I select “ftp” (or nfs) and enter the url (exactly the same which is in the ks.cfg) everything works and the installation runs until the end.

In the ks.cfg I’ve specified
url --url=“ftp://ip/path-to-rocky9
also tried with nts (ip:path)
I’ve also added the repo --name=“AppStream” … - that one is visible in the installation source menu.

I’ve downloaded the Rocky Linux 9.0 DVD, kernel etc. I took from that iso-file.

Thanks for any help,
kind regards


From looking at the centos documentation:

It should be:

url --url ftp://ip/path-to-rocky9

I’ve also has success with mirrorlist in the past:

url --mirrorlist=""
repo --name=AppStream --mirrorlist=""

Thanks Tom.

Hi Tom,
thanks for your answer. I’ve tried the url option in different ways, also the way you suggested it (–url ftp://… instead of --url=ftp://… ), the field in the installer still remains empty… I don’t know exactly whats behind, but probably the default “nearest mirror” does somehow prohibits filling the ftp url…

Kind regards


Not sure if this will help, but I’ve just been looking at using a kickstart with iso and confirm with my old templates I couldn’t get --url to work. Changing:




Fixed the problem for me with Rocky Linux 9.

Thanks Tom.

Hi Tom,
thanks for confirmation :wink: … I’ve recognised at the beginning of my problems that the ks= thing in the pxelinux/default configuration is depricated and replaced by inst.ks=. Unfortunatly that didn’t help also. Meanwhile I also tried it with rocky 8.6, but unfortunatly the same issue. I also switched from my kvm test environement to “physical” machines, same issue.
Now, I’m at that point, that I try to manipulate with the %pre section the anaconda default conf files - with restarting anaconda during the installation startup. That was kind of tricky, but I’m able now to switch the “closest mirror” default in the installation source menu to “http://”. But a URL isn’t filled in there - typing ip/path of the server by hand works, but isn’t really the thing i want…

Is there a config option in /etc/anaconda/product.d/rocky.conf to add a “default” url for the installation source menu?

my %pre:
#%pre --log=/tmp/ks_pre.log
sed -i ‘s/enable_closest_mirror = True/enable_closest_mirror = False/’ /etc/anaconda/product.d/rocky.conf
sed -i ‘s/default_source = CLOSEST_MIRROR/default_soruce = CDN/’ /etc/anaconda/product.d/rocky.conf
sed -i ‘s/systemctl restart anaconda//’ /run/install/ks.cfg
systemctl restart anaconda

my pxe APPEND line:
APPEND initrd=images/rocky/x86_64/8/initrd.img inst.repo= inst.ks=

Kind regards


I’ve just this on Rocky9 and the following works on kvm for me with rocky 9:

url --url=""
repo --name="AppStream" --baseurl=
# EPEL repo added for TLP
repo --name="epel" --baseurl=

isolinux menu entry looks like this:

label linux
  menu label ^Install Rocky Linux 8
  menu default 
  kernel vmlinuz
  append initrd=initrd.img inst.repo=cdrom inst.ks=cdrom:/rocky9-ks.cfg quiet

Regards Tom.