Recoll on Rocky Linux 8?


I’ve almost finished setting up my “perfect KDE desktop” on Rocky Linux 8. I’m about to tackle the missing bits that are not to be found in any third-party repository.

So far I managed to setup my own RPM repository, and I’ve already managed to build RPMS for owncloud-client and asunder, two applications I rely on.

For the last five years or so, I’ve been relying on Recoll as my main desktop search application. It really leaves the competition far behind in terms of speed and functionality. Unfortunately the package is nowhere to be found. I’ve tried to build it on mock from various Fedora SRPMS but all my build attempts failed.

Anybody managed to build/install Recoll on Rocky Linux 8?

Alternatively have you got a usable desktop search application to recommend ? (No, find and grep are not usable for my users.)

In Gnome (Rocky default), the search is already built in.

For Recoll, the build is here, but I don’t know where the git repo is
Building from source - - Recoll user manual

I tried to use GNOME for about a week, but I’m definitely a KDE user.

Yeah, I’ve seen the Recoll source. There are also some SRPMS around on, only none of them would build on RHEL 8.x or Rocky 8.x, since they all seem to require kdelibs4-devel.

You can build from the fedora srpm at with a little patch to the spec file:

--- recoll.spec~        2022-10-23 22:53:12.000000000 +0200
+++ recoll.spec 2022-11-07 00:19:37.911637767 +0100
@@ -17,7 +17,7 @@
 BuildRequires:  extra-cmake-modules
 BuildRequires:  gcc-c++
 # kio
-BuildRequires:  kdelibs4-devel
+#BuildRequires:  kdelibs4-devel
 BuildRequires:  kf5-kio-devel
 BuildRequires:  libxslt-devel
 BuildRequires:  make
@@ -98,11 +98,11 @@
 # kio_recoll -kde4
-pushd kde/kioslave/kio_recoll-kde4
+#pushd kde/kioslave/kio_recoll-kde4
 # gssp
 pushd gssp
@@ -145,11 +145,11 @@
 %files kio
 %license COPYING

A test build is here: mlampe/recoll Copr

1 Like

Thanks very much ! I’ll give this a spin as soon as I find the time.

So I just tried this out. I applied the patch to the specfile, but even then I got a showstopper error message informing me that the build dependency chmlib-devel could not be found.

So I simply configured the experimental repo in your link and downloaded the binary, which works perfectly.

Thanks very much !

You simply have to build chmlib before recoll to get this dependency. There are two packages in my copr: Packages for mlampe/recoll

If you want to see/download all rpms built, go to Index of /results/mlampe/recoll/epel-8-x86_64/05020570-chmlib/ and Index of /results/mlampe/recoll/epel-8-x86_64/05020569-recoll/.

1 Like

Thanks, I just figured that out ! Since I build my packages using mock, I’m currently experimenting with adding external repositories to the chroot environment. In short, build chmlib, add it to my own repo, and then build recoll.

Here you go: :slightly_smiling_face: