Quemu-kvm 100% Utilization

I have the setup as below

Rocky linux 8.5 x 64 Bit New Installation
Linux kvmdnshost.domain.com 4.18.0-348.2.1.el8_5.x86_64 #1 SMP Mon Nov 15 20:49:28 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
I have done a dnf update
If Guest VM is not running all is good but the moment I start the VM the host quemu-kvm process show 100% Cpu when top command is run and there are ping timeouts to this hosts
The hardware is a Cisco UCS Blade Server B200M3 , Intel Xeon Processor , 32 GB.

Appreciate your help and advice

Thanks and regards



What is your networking setup on the server? And also from the KVM side? On my desktop at home with KVM, utilising a single network card configured as a bridge (br0) with interface enp4s0 a member of that bridge (this may vary from machine to machine, be it eth0/enp2s0 or similar). The IP address of my machine is assigned to the bridge. In the office lab environment, I have a HP Proliant G7 with 3 network cards, one as a management interface for connecting to the host. The other two also setup as bridged interfaces for use with KVM - connected to two different subnets.

With this setup I don’t have ping issues. The machine at home is an Intel i5 4CPU, 48GB ram. When a VM is started, it’s noticeable to see one core hit 100%, and with the VM running (4cpu, 8gb ram), utilise about 25% of the CPU. It runs Gitlab, so this is why it’s a bit resource hungry, but I don’t get ping timeouts anyway. The office lab environment is Xeon, 32cpu, 148GB ram, but I doubt spec wise it is an issue, my home desktop is more comparable in terms of ram anyway, but it works fine with KVM. My laptop also has KVM with 32gb ram but then I’m only using the NAT network here.

You might want to check your network configuration for the server and KVM. A quick google did show problems with ping loss for macvtap but whether that is related to your problem or not - it’s hard to tell without more information from you on your server/kvm configuration.

Dear Iiwalker

Thanks for your immediate response. I really appreciate
I have 2 Network Cards and I have configured the bridge on only 1 network card and using this interface for the virtual machine . Guest VM is 4 CPU , 8 GB Ram
I just create a new VM and this happens the moment I run the VM.
I will still do more troubleshooting and post my update

Thanks and Regards


After starting the VM there is no OS booted yet. Is it still using 100% CPU after booting OS? My observation (caveat: I tried on a CentOS 7 kvm host right now) is that while sitting at grub prompt CPU is used 100%.