PPPoE failed to start: the PPP plugin /usr/lib64/NetworkManager/1.44.0-4.el9_3/libnm-ppp-plugin.so is not installed

I’m trying to enable a pppoe server on Rocky Linux 9 when I bring the interface up with ‘ifup ppp0’ I get the message in the subject above. Any help would be much appreciated.

dnf install NetworkManager-ppp
maybe helps

Thanks. I’ve tried that a number of times. See below.

[root@testfarm-PowerEdge-R450 ~]# dnf install NetworkManager-ppp
Last metadata expiration check: 3:37:43 ago on Wed 10 Apr 2024 04:12:11 AM EDT.
Package NetworkManager-ppp-1:1.44.0-5.el9_3.x86_64 is already installed.
Dependencies resolved.
Nothing to do.

Perhaps the problem is using ifup. Have you checked on the disk to see if /usr/lib64/NetworkManager/1.44.0-4.el9_3/libnm-ppp-plugin.so exists?

[root@rocky9 ~]# dnf provides */libnm-ppp-plugin.so
Updating Subscription Management repositories.
Last metadata expiration check: 1:30:28 ago on Wed 10 Apr 2024 12:23:07 PM CEST.
NetworkManager-ppp-1:1.44.0-5.el9_3.x86_64 : PPP plugin for NetworkManager
Repo        : UpWare_Rocky_Linux_Rocky_Linux_9_AppStream
Matched from:
Filename    : /usr/lib64/NetworkManager/1.44.0-5.el9_3/libnm-ppp-plugin.so

suggests the package provides it, so if you have that package installed, then it means the problem is ifup. Try using the Network Manager tools to configure and enable your ppp connection instead of ifup.

Also you will see that my example above shows a version newer than yours, which would suggest your system isn’t fully up-to-date. Try running dnf update to update your system packages as well. Maybe ifup will then start working when the system is in a sane and up-to-date state.

Thanks iwalker. I did a “dnf update” and now at least don’t get the plugin missing. Working on the rest of the pppoe set up now.

1 Like

The PPPoE server is up and running after I put the interfaces in the appropriate zones using firewall-cmd.

Thruput is much slower than the non-PPPoE connections. Not sure why, but top shows a pppoe process taking 65% CPU.