Poor video performance with oficial NVIDIA drivers

Hello everyone.

After some years on Windows, I’ve moved to Manjaro, but I got some issues with hardware and some other minors issues.

So I’ve decided to use a more stable linux version to transform my PC on a workstation for 3D and game development for linux (another machine for Win), them I decide to try Rocky. During the installation I’ve chosen workstation and chosen something about graphic on the right pane (don’t really remember what).

ASUS TUFF X570 motherboard
Ryzen 9 3900X
SAMSUMG EVO 970 (or 980, don’t remember).

I know my video card and processor are not the right choice, bottleneck and etc.

But my old video card has gone, so it’s what I have for now.

After some research I’ve added the official NVIDIA repo to DNF and them I’ve installed the official drivers.

The point is, GNOME and video playback are terrible, sometimes gnome ‘skip some frames’ while moving windows around, and the second monitor that is downscale to 1080P is even more terrible in all possible manners, just move the mouse around make the animation skip a lot of frames, something like when GPU hits 100% on Windows.

The movement of windows and etc have less quality than nouveur, but how I use Blender, Unity and Davinci Resolve, I need the official drivers. And the issues are not cable related.

So, there is some way to optimize it for now until I buy a new AMD GPU. Performance is really low, even if compared with Manjaro with fancy effects on KDE, where things run more smoothly. And being honest, I don’t want to wast more hours finding out another distro.

NOTE: I don’t know why, but Blender runs pretty fine while sculpting, little better than Manjaro.

And I know I should post some information about hardware and etc, but Manjaro forum commands doesn’t work on Rocky.

Sorry my bad English and thanks for the help.

Could you try installing the NVIDIA drivers via the RPM Fusion repository? Howto/NVIDIA - RPM Fusion

Sorry my delay, I was playing with OPENSUSE to see how things goes in there.

Decide to try Rocky again.

RPM Fusion makes things works like a charm with only one monitor, hard to describe how good it goes. Even internet looks faster.

And works like a pile of garbage with second monitor activated.

With two monitors system goes really down on overall performance.

Some other idea?

Hmm. Anything interesting showing up in logs?

I’m sorry. But I’m not a experienced Linux user to know how to check the logs. My most advanced adventure in Linux wast install Arch through command line with a tutorial. I don’t even know that there is a log for this kinda of thing.

I just installed a RHEL based distribution to turn my PC into a full time workstation instead of a personal computer, stability is really great.

How do I check the log?

TYVM for the support.

After the poor desktop environment performance on Rocky I’ve decided to try ALMA Linux (another RHEL based) to test the video settings and Blender performance.

With Alma, the desktop environment is just a little bit better in a fresh-clean install, but Blender performance is just around 1~3% worst on heavy 3D loads like sculpting than Rocky, but both are incredible stable.

After install the official NVIDIA drivers through their RHEL 9 repo. I’ve decided to tweak NVIDIA SETTINGS to take a look if I can get the same Rocky performance under ALMA, them I’ve discovered that by some weird reason, my secondary monitor was set to 24.something HZ.

It’s not a real issue with Alma, the ‘frame loss’ it’s ALMOST unnoticeable, but there a little flickering on the screen.

I’ve back to Rocky today, after a fresh install with NVIDIA proprietary drivers from RHEL 9 repo and set the HZ to 50~60 make the problem disappear, 24-30 causes the problem.

This problem with low HZ is persistent with RPM Fusion and official NVIDIA repo under X11, I’ve forgot to test Wayland under Rocky and ALMA.

So if you get something, try to check the HZ. I hope this can be useful to someone else using a mummy 10 series under Linux.

TY for the support.

Yes, but since these were clean installs, where exactly did you set the Hz in the first place? e.g. was it set on the monitor itself?
The NVidia proprietary driver is not part of Rocky or Alma.

The 24.something HZ is set by the system or drivers, I’ve done both installs with the second monitor detached from the HDMI port, due to another little weird problem that I’m having with the monitors under Linux, but this is for another post.

I’ve noticed the low frequency under NVIDIA settings, and set the right HZ in there, but, by some reason, NVIDIA settings do not ‘remember’ the HZ after reboot (I didn’t createad the X configuration file that the app suggests), so I’ve set the 60 HZ under GNOME config and it seems that its working fine after reboots.

Interface is fully functional and buttery smooth, and for the first in my life since I’ve buy this GPU, I can get the full performance of it under Blender : )

Inside of the monitor settings I’ve found nothing about the HZ, any way to ‘set’ it to 60. So maybe I’m missing something on the option or my monitor it’s broken again, alread fix one time over a year ago.