Install issues with UHD monitor

I have just come through an epic installation disaster of Rocky 8.4,
I have been running a very stable Centos 7 installation for many years
on a 1TB raid1 mirror (two seagate 1TB) with other mirrors for data
backup, my hardware is 2 2080Ti’s, 128GB ram, i9-10980XE CPU,
ASUS SAGE mobo. So, I thought I would upgrade the O.S. to Rocky,
first, I attached 2x M2 ssd’s and disconnected all the other drives, thinking
that I might make a raid1 from the SSD’s, but after trying multiple times
with the USB boot of Rocky and not having any luck, I decided to install
to one ssd which was successful, but when it came to rebooting after the
install all a got was screen lockup, I found that if I booted to a TTY, then
I could start Rocky with “startx”. I finally figured that it was the video
drivers which were causing the problem, so I downloaded the driver
from NVIDIA, blacklisted nouveau, installed the NVIDIA driver at the TTY,
finally got into Rocky, but I couldn’t change the resolution and the NVidia
app wasn’t installed, Rocky then became very unstable, I tried again to
install the NVIDIA driver, but then I got a lockup just before the login
screen, it was as if the video drivers were not compiled for the new kernel
which was not the case as I had just installed them which also compiles
the modules. So, bottom line, after two days and countless hours of trying,
I am back using good old Centos 7.9, Also I might add that I am not a
Linux noob, I have installed the o.s. and drivers many many times before
without any issues, looking back I think it had something to do with the
UHD screen (4k) and the fact that the nouveau driver was having
problems with it.

Got it all sorted, now I am on Rocky from Centos 7, the first issue was the
fact that you can only boot a Raid 1 as a normal bios boot, but nvme can
only be used in Uefi boot mode unless you do a hell of a lot of manual
work, which I didn’t have the energy to do, thus I booted with a single
nvme (1TB) M2 drive.
The second problem was with the Nvidia drivers which RHEL 8 docs
instructed to use, these clearly didn’t work and modified a lot of init
files, even after removing these drivers the modified files weren’t restored,
so after about 10 full install attempts, I followed the same manual method
of installing the drivers as I had with Centos 7 and it worked the way you
would have thought, so the docs from RHEL 8 are a no go for me in future.