Nvidia Graphics card not working after upgrade to 8.7

After the upgrade to 8.7 the Nvidia driver stop working.
I had installed NVIDIA-Linux-x86_64-470.63.01.run on 8.6 and it was working fine.
It’s not a big deal, I reinstalled NVIDIA-Linux-x86_64-515.76.run and it works now.
Maybe DKMS modules had not automatically been rebuilt when the new kernel was installed.
I check and dkms was installed.
dkms.noarch 3.0.8-1.el8 @epel

NVidia has repo with RPM packages so one should have no need for the ghastly *.run
Their packaged version appears to dkms ok (at least for el9).

Had no issues with Nvidia akmod drivers from RPM Fusion, kernel modules were automatically built after reboot.


So, the advice is to install Nvidial from RPM Fusion not the NVIDIA-Linux-xxxxxx.run
Can someone point to a good howto?


The only real gotcha with these are that you have to turn off secure boot in the bios

That works with kernel 4.18.0-372 but I have 4.18.0-425 since the upgrade to 8.7

Install akmod-nvidia, I use it with Rocky 8.7, kernel 4.18.0-425.3.1.el8.x86_64. Modules are automatically rebuilt if the kernel is updated.

EDIT: I installed Rocky before Secure Boot was available, if you have Secure Boot enabled you need a private signing key for the modules. Haven’t tried it myself but Red Hat’s documentation is here: Chapter 3. Signing kernel modules for secure boot Red Hat Enterprise Linux 8 | Red Hat Customer Portal.