Nvidia driver update 9.0 -> 9.1

My machine failed to upgrade the nvidia driver correctly for the 9.1 kernel from 9.0

I am using 470 series (my card is deprecated on the newer drivers) - this worked perfectly in 9.0

When i rebooted into 9.1 - stated that it had to revert to nouveau as nvidia module could not load -

I checked akmod and nvidia drivers are installed.

I rebooted into 9.0 kernel and it still worked as previously with the nvidia driver

Do I have to uninstall akmod and reinstall? Any other suggestions?


Yes, I’ve had this exact same problem with Fedora when upgrading from 36 to 37 for example. I had to remove all the akmod-nvidia stuff, plus any other kmod-nvidia stuff that might be installed. Then reboot, and reinstall akmod-nvidia or akmod-nvidia-470xx package. It should then work after this on reboot.

TBH it should have worked, but perhaps there is a conflict in packages that are installed.

NVidia drivers packaged by whom? I know that ELRepo does not build kmod-nvidia for el9
and negativo17 nor NVidia’s own repo do not have legacy. So, RPMfusion or ??
(I will need the 470 eventually.)

@jlehtone yes I believe rpmforge for RL9 and higher using the akmod packages.

RPMforge (aka RepoForge) is different, and now dead project.

Saw the RPM Fusion packages, akmods and all. Versions 340xx, 470xx, and current.

On OP topic, what would make the akmod to fail to build on boot and how to diagnose/avoid that?

Lol sorry I meant rpmfusion.

Check the logs in /var/cache/akmods/, might give you a hint.

I’ve actually wondered this same thing. I experienced it twice, recently when upgrading FC36 to FC37. Now I’m not sure if the distro upgrade process is involved in it or not. However that said, I believe I might have also messed it up the first time I experienced it, as I found I also had kmod-nvidia packages also installed. From when I fixed it again recently, like a week or so ago after upgrading I removed all the nvidia stuff, and then just installed akmod-nvidia to get it back again. For some reason it failed to build. I didn’t dig further to find out why. Time will tell if it occurs again during the next distro upgrade in about 6 months or so.

So, I could have caused it myself due to installing unnecessary kmod packages that might have caused a conflict. If it occurs again, I’ll have to dig deeper in the logs and find out why. I thought a dnf reinstall would help, but it seems only a completely remove and install will work. At least when I’ve gone through it twice anyhow.

Since RL9 release and elrepo not making nvidia packages, I believe the way forward now is to use the rpmfusion repositories.

I suppose the procedure requires the kernel-devel package. There is a known issue:


Building kernel modules is problematic until the fixed version becomes available.

5.14.0-162.6.1.el9_1.0.1.x86_64 addresses the kernel-devel issue.

thank all of you for the terrific input and community effort!!

please note that the latest kernel update did fix the issue:

sudo dnf update

sudo dnf reinstall nvidia-driver-470


this time it worked like a charm


OK educate me: I am currently stuck using the nouveau nvidia driver. No matter how many times I have tried to install the nvidia driver/s it has lead to disaster. I have TRIED to do it via kmod-nvidia, now I hear about something called “akmod-nvidia”. Does “akmod-nvidia” replace “kmod-nvidia”? Which repo di I need to enable?? Any articles on how to get Nvidia to work on RL 8.7 using “akmod-nvidia”?? Any help would be appreciated.


D’ Cat

While this thread is about el9, the major driver sources:
RPM Fusion and NVidia’s own yum repository each do have instructions for el8 too.
Furthermore, ELRepo does have NVidia drivers for el8 (but not for el9).