"No IRQ handler" after clean install of R9

I have an old PC Engines APU2c2 (PC Engines apu2 system boards), bought in 2016. This has been running C7 nicely since then.

Yesterday I installed a new (blank) mSATA card in it and then deployed R9 “minimal install”. Took a few attempts to get the partitioning the way I wanted (it’s a lot harder when all you have is a serial console), but I got there :slight_smile:

However on reboot the following “emergency” messages appear

__common_interrupt: 1.55 No irq handler for vector
__common_interrupt: 2.55 No irq handler for vector
__common_interrupt: 3.55 No irq handler for vector

(That’s one per CPU core, but not core 0 ?!)

The machine appears to be working (although I haven’t stress tested it).

Googling doesn’t help much; hints around disabling iommu; I’ve tried iommu=off amd_iommu=off intel_iommu=off but the messages still remain.

According to /proc/interrupts I see

55: 0 0 0 0 IO-APIC 16-fasteoi ath9k

So I removed that piece of hardware (since I’m not using Wifi on this machine). Now on reboot I still get the same messages, but /proc/interrupts shows nothing on 55

Also lspci -v | grep -i irq shows nothing on that IRQ.

I could try flashing a new bios but I’m loathe to do this except as last resort (recovery isn’t easy if it goes wrong).

Has anyone else seen this message and have any ideas?

FWIW,

CPU: AMD GX-412TC SOC
BIOS:
        Vendor: coreboot
        Version: 88a4f96

Now would be a good time to update the bios. Simply because of the age of the HW. You should not do this if it is used in production… https://pcengines.github.io/ - the process is straight forward.

Yeah, I’d found the BIOS updates, but I’m hesitant; if it goes wrong then recovery appears to be a PITA.

But APU bios upgrade says they’ve done hundreds without issue, so maybe it’s worth the risk!