Network Manager goes to sleep, loosing internet access

Hi everyone, again an issue with Network Manager. I have a lot of VPS and out of nowhere on some of them I lose internet access.

After checking the settings (network-scripts configs) everything seems correct. The interface eth0 though didn’t have an IP address. I found that sending the nmcli n off and nmcli n on fixed the issue, but it’s impossible to leave the server works like this.

After searching in the logs, I found that the issue begins when I have these logs:

Dec  3 15:23:52 vmi710830 NetworkManager[877]: <info>  [1701609832.1370] manager: disable requested (sleeping: no  enabled: yes)
Dec  3 15:23:52 vmi710830 NetworkManager[877]: <info>  [1701609832.1372] manager: NetworkManager state is now ASLEEP
Dec  3 15:23:52 vmi710830 NetworkManager[877]: <info>  [1701609832.1375] audit: op="networking-control" arg="off" pid=51031 uid=0 result="success"
Dec  3 15:23:52 vmi710830 NetworkManager[877]: <info>  [1701609832.1375] device (lo): state change: activated -> deactivating (reason 'sleeping', sys-iface-st>
Dec  3 15:23:52 vmi710830 NetworkManager[877]: <info>  [1701609832.1383] device (eth0): state change: activated -> deactivating (reason 'sleeping', sys-iface->
Dec  3 15:23:52 vmi710830 NetworkManager[877]: <info>  [1701609832.1431] device (lo): state change: deactivating -> disconnected (reason 'sleeping', sys-iface>

After that any action regarding NetworkManager in the logs sets to unamanged or disconnected with reason sleeping. systemctl status NetworkManager begins with networking is disabled by state file. At
/var/lib/NetworkManager there is a file called NetworkManager.state with NetworkingEnabled=false. If I delete this file and restart NetworkManager it works as expected.

Two workarounds to get this working is to nmcli n off/on or detelete the NetworkManager.state and restart NetworkManager.

These machines are based on 9.2 cloud images and do not have a GUI that may set the networkmanager to sleep. Any idea why this may happening?

EDIT: A few lines after ASLEEP, it show the audit: op=“networking-control”, arg=offf and a pid which is currently not availble to see. Is there a possible chance that ExpressVPN sending this commands? It’s really weird.

Install NetworkManager-config-server and reboot

Thanks will try these to see if it fixes the issue!