dnf upgrade --security on a Rocky 8.7 vm, we received an error message that I do not understand. One error appears to be that the upgrade cannot be performed because the upgrade would re-install existing glibc packages and re-installing the existing packages would conflict with the upgrade of those packages. The other error appears to be that the upgrade cannot be performed on account of the requirements of an existing package that will be replaced in the upgrade.
Error: Problem 1: glibc-2.28-211.el8.i686 has inferior architecture - cannot install both glibc-2.28-225.el8_8.6.x86_64 and glibc-2.28-211.el8.x86_64 - cannot install the best update candidate for package glibc-2.28-211.el8.i686 - cannot install the best update candidate for package glibc-2.28-211.el8.x86_64 Problem 2: package glibc-gconv-extra-2.28-211.el8.i686 requires glibc-common = 2.28-211.el8, but none of the providers can be installed - cannot install both glibc-common-2.28-225.el8_8.6.x86_64 and glibc-common-2.28-211.el8.x86_64 - cannot install the best update candidate for package glibc-gconv-extra-2.28-211.el8.i686 - cannot install the best update candidate for package glibc-common-2.28-211.el8.x86_64
dnf list --installed glibc* shows the 2.28-211.el8 versions of the glilbc packages already is installed:
# dnf list --installed glibc* Installed Packages glibc.i686 2.28-211.el8 glibc.x86_64 2.28-211.el8 glibc-common.x86_64 2.28-211.el8 glibc-devel.x86_64 2.28-211.el8 glibc-gconv-extra.i686 2.28-211.el8 glibc-gconv-extra.x86_64 2.28-211.el8 glibc-headers.x86_64 2.28-211.el8 glibc-langpack-en.x86_64 2.28-211.el8
dnf check-update glilbc* shows all would be updated to 2.28-225:
# dnf check-update glibc* Last metadata expiration check: 0:27:57 ago on Sun 19 Nov 2023 05:55:06 PM PST. glibc.i686 2.28-225.el8_8.6 glibc.x86_64 2.28-225.el8_8.6 glibc-common.x86_64 2.28-225.el8_8.6 glibc-devel.x86_64 2.28-225.el8_8.6 glibc-gconv-extra.i686 2.28-225.el8_8.6 glibc-gconv-extra.x86_64 2.28-225.el8_8.6 glibc-headers.x86_64 2.28-225.el8_8.6 glibc-langpack-en.x86_64 2.28-225.el8_8.6
dnf upgrade indicate glibc-2.28-211.el8.x86_64 would re-installed (Problem 1) when it already is installed and, as shown by dnf check-update, would be upgraded to 2.28-225?
Why are the requirements of glibc-gconv-extra-2.28-211.el8.i686 taken into account (Problem 2) when dnf check-update shows that package will be replaced by glibc-gconv-extra.i686.2.28-225.el8_8.6?
What would be the best way to resolve these errors so that we can proceed with the upgrade?