Mount CIFS, SMB 1.0, plain text password

I am currently in a context of assembly between a Rocky 9.3 client and a NAS.
Due to the restrictions I have regarding a Google LDAP. I have to work with SAMBA 1.0.
To do this I must use plain text password transmission during mounting/access. When I modify the configuration of my samba on my rocky client, and I execute an access with SMBCLIENT, everything works fine. If I do the same thing with a CIFS mount. I have an error. The problem is simply that I cannot force the modification of the CIFS SecurityFlags. I always get an error that the value is not correct.

“echo 0x30030 > /proc/fs/cifs/SecurityFlags”
ofc i did that in root context

how can I force the application of a value in CIFS security? the “sec” parameter in the mount line gives me the same errors. I think for security reasons, the value is blocked/prohibited. But I have no choice in my context.

This came up a couple years ago when support was removed in the kernel for version 1.0 mounts. I think that was restored in some fashion.

Did you add ver=1.0 to the options line as seen below?

sudo mount.cifs -o ver=1.0,username=$USER,uid=$USER,gid=$USER,credentials=/home/$USER/.samba/.$USER //SERVER/SHARE ~/SHARE

If you don’t use a credentials file then you would have to put the password on the same options line. You may have to substitute your user numeric uid,gid instead of the username.