Livecd-creator aborts on Rocky-8.9

I’ve had consistent, reliable results from Livecd-creator on Rocky 8.8.
The platform I’ve used for livecd-creator work on my HP Compaq DC5800
test machine is Rocky-8.8-minimal with a light e16 desktop environment
configured as detailed in
Rocky Linux Forum - The community hub for the Rocky Linux project..

With a platform upgrade to Rocky-8.9, every livecd-creator run proceeds
normally for about 40 minutes, but in the end, aborts with the message
‘Error creating Live CD: “mksquashfs /var/tmp/imgcreate-…
/squashfs.img -comp xz’ exited with error(1)

The squashfs-tools and livecd-creator package versions for Rocky-8.9 are
unchanged from Rocky-8.8, so it’s not clear what is going wrong.

Len E.

livecd-creator is not recommended as it has various problems that may or may not be fixed in EPEL. You recommended to use livemedia-creator instead.

Hi Nazunalika:

I installed the lorax packages for livemedia-creator on my Rocky-8.9 platform
and tried a run with one of my previously-used kickstarts:

sudo livemedia-creator --make-iso --no-virt --anaconda-arg="–product Rocky Linux” --ks=rocky-8-xfce-customelrepo.ks

The run aborted quickly with the message
dasbus.error.DBusError: umount of /run/user/1000 failed (32)

The /var/log/anaconda directory contained a large syslog file and a large journal.log file.

I don’t know how to use grep to try and analyze the contents of the files.

Len E.

You are attempting to run it on a system without using mock and you are missing critical switches needed to make it work. I would highly suggest following the directions on the page I linked above. The instructions suggest:

  • Install mock
  • Add user to the mock group
  • Use mock and install the necessary packages into the mock root
  • Use the working example command as a starting point (--anaconda-arg is not used; there is no reason to specify this nor --product, anaconda figures this out on its own)

Your command you’ve provided is using sudo (not required), you’re using an unneeded argument (--anaconda-arg), and you’re missing at least --iso-name, --resultdir, --releasever, --project, and --nomacboot.

% sudo dnf install epel-release -y
% sudo dnf install mock -y
% sudo usermod -a -G mock user
% mock -r rocky-8-x86_64 --init
% mock -r rocky-8-x86_64 --install lorax-lmc-novirt vim-minimal pykickstart git
% sudo setenforce 0
% sudo cp rocky-8-xfce-customelrepo.ks /var/lib/mock/rocky-8-x86_64/root/builddir
% mock -r rocky-8-x86_64 --shell --isolation=simple --enable-network
% livemedia-creator --ks rocky-8-xfce-customelrepo.ks \
  --no-virt \
  --resultdir /var/lmc \
  --project="Rocky Linux" \
  --make-iso \
  --volid Rocky-XFCE-8-Custom \
  --iso-only \
  --iso-name Rocky-XFCE-8-Custom.iso \
  --releasever=8 \

Hi Nazunalika:

I followed your detailed summary instructions to the letter on my Rocky-8.9
platform and the livemedia-creator run failed in a manner which will be
described below.

The screen messages on the livemedia-creator run indicated that a disk size of
6144Mib would be used, and given my 15GB partition only had ~5500mb unused
before starting the run, I thought that my partition might be too small, even with
a 4GB swap partition enabled.
Therefore, I rebuilt my e16-based test platform on my HP Pavilion m8247C test
machine with a 25GB root partition and a 15GB /home partition.

I tried my livecd-creator run and it completed normally.

I tried the livemedia-creator run and it failed in the same manner as it did on
the original test platform. The following is the screen output from the run:

Start: shell
<mock-chroot> sh-4.4# livemedia-creator --ks rocky-8-xfce-elrepo27.ks \
> --no-virt \
> --resultdir /var/lmc \
> --project="Rocky Linux" \
> --make-iso \
> --volid Rocky-XFCE-8-Custom \
> --iso-only \
> --iso-name Rocky-XFCE-8-Custom.iso \
> --releasever=8 \
> --nomacboot
2023-12-03 19:49:06,159: livemedia-creator v28.14.70-1
2023-12-03 19:49:06,159: selinux is Disabled
/usr/lib/python3.6/site-packages/pykickstart/commands/ KickstartParseWarning: A partition with the mountpoint / has already been defined.
  warnings.warn(_("A partition with the mountpoint %s has already been defined.") % pd.mountpoint, KickstartParseWarning)
2023-12-03 19:49:06,312: disk_img = /var/lmc/lmc-disk-4k5fx9pg.img
2023-12-03 19:49:06,312: Using disk size of 6146MiB
2023-12-03 19:49:07,249: Running anaconda.
2023-12-03 19:59:10,972: Starting installer, one moment...
2023-12-03 19:59:10,973: terminal size detection failed, using default width
2023-12-03 19:59:10,973: anaconda for Rocky Linux 8 (pre-release) started.
2023-12-03 19:59:10,973: 19:59:10 Service org.fedoraproject.Anaconda.Modules.Storage has failed to start: Failed to activate service 'org.fedoraproject.Anaconda.Modules.Storage': timed out (service_start_timeout=600000ms)
2023-12-03 19:59:21,150: Running anaconda failed: process '['anaconda', '--kickstart', '/builddir/rocky-8-xfce-elrepo27.ks', '--cmdline', '--loglevel', 'debug', '--dirinstall', '--remotelog', '']' exited with status 1
2023-12-03 19:59:21,299: Install failed: novirt_install failed
2023-12-03 19:59:21,299: Removing bad disk image
2023-12-03 19:59:21,301: ERROR: Image creation failed: novirt_install failed
2023-12-03 19:59:21,301: Image creation failed: novirt_install failed
<mock-chroot> sh-4.4# exit
Finish: shell
Finish: run

Given the quirks that livecd-creator exhibits from time-to-time, it is
certainly desirable to be able to achieve reliable results with livemedia-creator.

Len E.

Hi Nazunalika:

Making some progress on the difficulty with Livemedia-creator.

Some preliminary obervations:

-I’ve belatedly realized that we’ve faced this problem before, last January,
when you were guiding me through the use/creation of kickstart files, as
described in the post,
Installation Problem with Rocky-8-XFCE-x86_64-latest - #13 by LenE

-A difficulty/some confusion was created by the fact that the
Rocky-8.9-minimal.iso was configured with kernel-4.18.0-513.5.1.el8_9.x86_64,
and subsequently there is a new version available,
The mock software always uses the latest kernel available, so before working
with mock, it is essential to update to the latest kernel,
sudo yum upgrade kernel kernel-*, in order to achieve valid results.

-Further tests on my HP Compaq DC5800 failed in the same way as previously.
It only has 2GB of memory, and it may not be enough to run livemedia-creator ??

My HP Pavilion Media Center M8247c has 3GB of memory, and the sata disk
On the latest mock runs, in the mock -r rocky-8-x86_64 --install command of
your procedure, I inserted kmod-sata_nv-3.5-9.el8_9.elrepo.x86_64.rpm in the
front of the package list.

The following shows the test results:

2023-12-14 18:33:30,990: Starting automated install...
2023-12-14 18:33:30,990: ================================================================================
2023-12-14 18:33:31,012: ================================================================================
2023-12-14 18:33:31,012: Installation
2023-12-14 18:33:31,012: 
2023-12-14 18:33:31,012: 1) [x] Language settings                 2) [x] Time settings
2023-12-14 18:33:31,023: (English (United States))                (US/Eastern timezone)
2023-12-14 18:33:31,023: 3) [!] Installation source               4) [!] Software selection
2023-12-14 18:33:31,023: (Error setting up software               (Error checking software
2023-12-14 18:33:31,023: source)                                  selection)
2023-12-14 18:33:31,023: 5) [ ] User creation
2023-12-14 18:33:31,024: (No user will be created)
2023-12-14 18:33:31,024: 
2023-12-14 18:33:31,024: 
2023-12-14 18:33:31,024: The installation was stopped due to an error which occurred while running in non-interactive cmdline mode. Since there cannot be any questions in cmdline mode, edit your kickstart file and retry installation.
2023-12-14 18:33:31,024: The exact error message is:
2023-12-14 18:33:31,024: 
2023-12-14 18:33:31,024: The following mandatory spokes are not completed:
2023-12-14 18:33:31,024: Installation source
2023-12-14 18:33:31,024: Software selection.
2023-12-14 18:33:31,024: 
2023-12-14 18:33:31,025: The installer will now terminate.

The two runs terminated with this same result.
The first one used Rocky-8-XFCE.ks, the 2nd used rocky-8-xfce-elrepo.ks.

Given that these kickstarts were created by an expert, I don’t understand why
these messages came up.

Len E.

Hi Nazunalika:

Some good news with Livemedia-creator:

I discovered a blunder I made in the tests; the copies of Rocky-8-XFCE.ks and
rocky-8-xfce-elrepo.ks that I used were early copies which had the explicit 8.7
version number in the URL’s for the Rocky repos. I quickly altered the
Rocky-8-XFCE.ks copy, with the version number simply 8, and reran the test
on the HP Pavilion Media Center M8247c as previously described.
It completed normally after just over 1 hour of run time.

I’ll check a few more things on my HP Compaq DC5800 test environment, and
then enter some final comments and close off the post.

Thank you for your patience !!

Len E.

Hi Nazunalika:

Subsequent to earlier test failures on my HP Compaq DC5800, I rebuilt my
test environment there also. Originally, I had a 13GB root partition and a
17GB /home partition, but given the extensive activity in the /var directory
with mock processing, I reinstalled with the 17GB partition as root, the 13GB
partition as /home. (If/when rocky 8.10 comes out, I’ll use a separate /var
partition, which makes partition allocation easier with smaller pieces).

Some livemedia-creator documentation on the web mentioned a memory parameter
ram with the default value being 1024 MB. The HP Compaq DC5800 has 1781352
KB available memory from a nominal 2GB. Htop showed after bootup, and no
applications selected, that only about 220 MB was in use. Therefore, on the mock
run with the url-corrected rocky-8-xfce-elrepo.ks file, the only change to your
detailed summary instructions was a --ram 1560 parameter addition to the
livemedia-creator command. (The HP Compaq DC5800 uses Intel disk
controllers, so the kmod rpm addition wasn’t applicable).

The mock run completed successfully, and (again) took just over an hour.
It’s not clear if the addition of the --ram 1560 parameter had any impact/relevance
at all. The /var/lib/mock/rocky-8-x86_64/result/hw_info.log file showed that
of the 1781352 KB memory available, only 243344 KB was used.

Thanks for all your help is closing this matter out successfully !!

Len E.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.