LibreOffice window decorations gone under Rocky 8/KDE


I’ve been running Rocky Linux 8 with KDE from EPEL for the last couple years or so.

On two fresh installations performed today, I have a weird problem. Seems like LibreOffice’s window decorations are gone. No buttons to maximize, minimize and close.

Any idea what’s going on here ?

I’ll answer this myself, since I just found the culprit. Turns out SDDM’s default session for KDE is Wayland. Usually I only ever use X11, since Wayland has way too many showstopping bugs (at least under RHEL & clones). Launched a new X11 session, and everything works like a charm.

Which leads me to a follow-up question. Apparently there’s no sane way to remove Wayland entirely from my system. Is there a way to disable Wayland in the SDDM menu and make X11 the default choice ?

Are there dirs /usr/lib/sddm/sddm.conf.d/ and /etc/sddm.conf.d/ or file /etc/sddm.conf and what is in them? Option DisplayServer? See sddm.conf(5) — Arch manual pages

Although, if you can choose both X11 and Wayland sessions, then that might not be the solution.
Do possible (Wayland) sessions come from /usr/share/wayland-sessions/?

Can you tell us some of them?

My guess is that the issues are related to older software not knowing how to use Wayland.

That did the trick:

- name: Default to X11 session in SDDM
    remote_src: true
    src: /usr/lib/sddm/sddm.conf.d/x11.conf
    dest: /etc/sddm.conf.d/
    owner: root
    group: root
    mode: 0644

Thanks !

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.