HP ProLiant DL180 G6 with P410 Smart Array

I want to breathe new life into an HP ProLiant DL180 G6 with P410 Smart Array 12-bay server that was purchased in early 2012 and hasn’t really done much for the last decade. It used to run Open-E DSS V6 software but the licence for that expired long ago. Will the latest Rocky run on it, or should I go back to something like CentOS-6 as the RedHat site only certified the hardware up to RHEL-6.x?

Many thanks

I would just try it and see if it works. Chances are it will. A G6 isn’t that old so should work.

Get a “live” image (of any linux) or just the Rocky installer, boot with it, and run lspci -nn.
Record the device id’s of at least storage controller and NICs.
Search those id’s from output of modprobe -c on Rocky system.
If all are not found, then search ELRepo; they probably have kmods for missing devices.

I guess that elrepo kmod for the disk controller (cciss?) will be necessary.

Quite possible. I did install (CL8.3, summer 2020) on Fujitsu (~2010 model) that has LSI SAS1068E controller. RHEL 8 has no support for it (but ELRepo has ‘kmod-mptsas’) so the installer did not see any disk(s) on the system.

The key is to get that device id first.

Installer had no driver for RAID, but installer can load a “driver disk”, even from net.
If I’d install RL 8.5 now to that Fujitsu, I would append this to installer kernel’s command-line:


Alas, there is no “cciss” among those dd’s.
This says that hpsa replaced cciss (upstream): cciss(4) - Linux manual page
And (hpsa in upstream support(s|ed) P410: hpsa(4) - Linux manual page

Is the device id [103c:3243]? https://www.suse.com/support/kb/doc/?id=000018202

[AL8.5]# modinfo hpsa | grep -i "103c.*324.bc"
alias:          pci:v0000103Cd0000323Asv0000103Csd0000324Bbc*sc*i*
alias:          pci:v0000103Cd0000323Asv0000103Csd0000324Abc*sc*i*
alias:          pci:v0000103Cd0000323Asv0000103Csd00003249bc*sc*i*
alias:          pci:v0000103Cd0000323Asv0000103Csd00003247bc*sc*i*
alias:          pci:v0000103Cd0000323Asv0000103Csd00003245bc*sc*i*
alias:          pci:v0000103Cd0000323Asv0000103Csd00003243bc*sc*i*
alias:          pci:v0000103Cd0000323Asv0000103Csd00003241bc*sc*i*

Looks like those “Smart Array” models do have support.

Things get more interesting if network cards have no drivers …

1 Like

Good news, folks! I booted the DL180 successfully from a USB stick built from Rocky-8.5-x86_64-minimal.iso, told it to auto-partition the 12TB RAID drive, configured a network interface and the other bits and bobs “minimal” asks you for (but NO additional packages, just the basic server) and off it went and created me a bootable system. Marvellous!

The only tweakery I had to do was edit /etc/default/grub to add “vga=794” to GRUB_CMDLINE_UNIX and run grub2-mkconfig to get the graphics adapter to run in a mode my ancient monitor could cope with - without this my screen kept showing a “graphics resolution not supported message” which was mildly annoying - I wonder why it didn’t autodetect - maybe because the native resolution is 1440x900 - and maybe I shouldn’t be using “vga=” in 2022, but it worked so what the heck!

The other thing I had to do, on the DL180 side of things, was replace all the disk drives because the old ones had worn out, then boot into the Option ROM Configuration for Arrays utility, create a logical drive (4x 4TB disks in a RAID5 configuration) and set is as the boot volume. Simples!

Hi, I have a similar issue with my HP sl165s g7. Tried many monitor but failed. When booting, my screen says “change resolution to 1920x1080x60” :frowning: Is there a hope to use, because I have 39 servers left to install Rocky 8.5.

Installer has text-mode. Once you get one system installed, its /root/ has kickstart-file with the choices you made. With that you can do non-interactive install on similar machines.

1 Like

When boot screen with tab key, entered text and installed successfully, thanks @jlehtone :blush:. But after a restart, despite setting at boot vga=31A, the screen resolution error comes again. When this error happens, remote login doesn’t work. So I need to solve this step, disable unsupported settings and let the boot complete. :frowning: My server is an old one: hp sl165s g7 from the date 2011.

What package selection did you choose? Something that did install GUI? You should have no need for GUI in a cluster.

Add systemd.unit=multi-user.target to the kernel options. When (if) system boots to text mode, run:

systemctl set-default multi-user.target

I installed webmin for management gui after install minimum. I will try that command. Thank you.