How to migrate from KDE Plasma to Gnome in Rocky Linux?

If this is possible without tearing everything down and starting over, I’d like to migrate from KDE Plasma to Gnome as my desktop.

I’ve been using my Rocky Linux system for several months, and I’m very happy with it. My most important desktop app is VirtualBox running Windows 10 Pro in a guest VM . I started with the RL + KDE iso posted here over the summer.

I continue to have a growing number of frustrations with KDE Plasma. Today’s issue is just the latest.

I hope someone can help show me a way to migrate from KDE Plasma to Gnome, hopefully without having to remove and replace desktop tools – especially VirtualBox.

You just install the gnome packages? (There should be a dnf group to conveniently include most of them.)

Hi,

Just tried this on gnome boxes:

sudo dnf groupinstall workstation

Its optional but I would switch to gdm:

sudo systemctl disable sddm
sudo systemctl enable gdm

Reboot

On the login screen click the cog and click one of the standard sessions (wayland or x11).

It should now default to one of these:

Also optional removing kde:

sudo dnf groups remove "KDE Plasma Workspaces"

Thanks Tom.

1 Like

I did the above (as root):

  1. dnf group install
  2. systemctl disable sddm
  3. systemctl enable gdm

This seems to have installed v8.5 without breeze. The first few times I restarted, I got a huge virtual keyboard. I clicked the “Enter” key and got login screen with a dropdown at the top left. I tried several choices that mentioned “wayland” and they didn’t work (I got a “Login failed” and a complaint about the missing “breeze”.

When I chose “Standard/Xll”, it put the system into a state where it immediately fails at startup.

When the system attempts to start, instead of a login screen I get white screen with text that says “Oh no, something has gone wrong …” There is a “Log Out” button that does nothing.

I’m able shell into the system, so it’s running. It’s the desktop that seems broken. Suggestions?

Here are some perhaps interesting excerpts from the end of journctl …

Nov 20 18:52:16 localhost.localdomain gnome-shell[2324]: Failed to create backend: No GPUs found with udev
Nov 20 18:52:16 localhost.localdomain gnome-session[2249]: gnome-session-binary[2249]: WARNING: App 'org.gnome.Shell.desktop' >
Nov 20 18:52:16 localhost.localdomain gnome-session-binary[2249]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Nov 20 18:52:16 localhost.localdomain gnome-session-binary[2249]: Unrecoverable failure in required component org.gnome.Shell.>
Nov 20 18:52:16 localhost.localdomain systemd[2185]: Started Sound Service.
Nov 20 18:52:16 localhost.localdomain systemd[2185]: Reached target Default.
Nov 20 18:52:16 localhost.localdomain systemd[2185]: Startup finished in 262ms.
Nov 20 18:52:16 localhost.localdomain gdm-launch-environment][2124]: pam_unix(gdm-launch-environment:session): session closed >
Nov 20 18:52:16 localhost.localdomain gdm-launch-environment][2124]: GLib-GObject: g_object_unref: assertion 'G_IS_OBJECT (obj>
Nov 20 18:52:16 localhost.localdomain gdm[1998]: Gdm: GdmDisplay: Session never registered, failing
Nov 20 18:52:16 localhost.localdomain systemd-logind[1456]: Session c1 logged out. Waiting for processes to exit.
Nov 20 18:52:16 localhost.localdomain systemd[1]: session-c1.scope: Succeeded.
Nov 20 18:52:16 localhost.localdomain systemd-logind[1456]: Removed session c1.
Nov 20 18:52:16 localhost.localdomain systemd[1]: Received SIGRTMIN+21 from PID 608 (plymouthd).
Nov 20 18:52:16 localhost.localdomain systemd[1]: Started Hold until boot process finishes up.
Nov 20 18:52:16 localhost.localdomain kdumpctl[1994]: kdump: kexec: loaded kdump kernel
Nov 20 18:52:16 localhost.localdomain kdumpctl[1994]: kdump: Starting kdump: [OK]
Nov 20 18:52:16 localhost.localdomain systemd[1]: Started Crash recovery kernel arming.
Nov 20 18:52:16 localhost.localdomain systemd[1]: Reached target Multi-User System.
Nov 20 18:52:16 localhost.localdomain systemd[1]: Reached target Graphical Interface.
Nov 20 18:52:16 localhost.localdomain systemd[1]: Starting Update UTMP about System Runlevel Changes...
Nov 20 18:52:16 localhost.localdomain systemd[1]: systemd-update-utmp-runlevel.service: Succeeded.
Nov 20 18:52:16 localhost.localdomain systemd[1]: Started Update UTMP about System Runlevel Changes.
Nov 20 18:52:16 localhost.localdomain systemd[1]: Startup finished in 12.431s (firmware) + 4.955s (loader) + 772ms (kernel) + >

I’ve been reviewing the log from `dnf groupinstall workstation"

I see this apparent anomaly:

  Running scriptlet: qemu-kvm-common-15:4.2.0-59.module+el8.5.0+670+c4aa478c.x86_64                      310/932
[sss_cache] [sysdb_domain_cache_connect] (0x0010): DB version too old [0.22], expected [0.23] for domain implicit_files!
Higher version of database is expected!
In order to upgrade the database, you must run SSSD.
Removing cache files in /var/lib/sss/db should fix the issue, but note that removing cache files will also remove all of your cached credentials.
Could not open available domains
[sss_cache] [sysdb_domain_cache_connect] (0x0010): DB version too old [0.22], expected [0.23] for domain implicit_files!
Higher version of database is expected!
In order to upgrade the database, you must run SSSD.
Removing cache files in /var/lib/sss/db should fix the issue, but note that removing cache files will also remove all of your cached credentials.
Could not open available domains
[sss_cache] [sysdb_domain_cache_connect] (0x0010): DB version too old [0.22], expected [0.23] for domain implicit_files!
Higher version of database is expected!
In order to upgrade the database, you must run SSSD.
Removing cache files in /var/lib/sss/db should fix the issue, but note that removing cache files will also remove all of your cached credentials.
Could not open available domains
[sss_cache] [sysdb_domain_cache_connect] (0x0010): DB version too old [0.22], expected [0.23] for domain implicit_files!
Higher version of database is expected!
In order to upgrade the database, you must run SSSD.
Removing cache files in /var/lib/sss/db should fix the issue, but note that removing cache files will also remove all of your cached credentials.
Could not open available domains

This complaint was repeated several times.

The command did appear to finish successfully – here’s the last few lines:

  vte291-0.52.4-2.el8.x86_64
  xdg-desktop-portal-gtk-1.6.0-1.el8.x86_64
  xdg-user-dirs-gtk-0.10-13.el8.x86_64
  xorg-x11-server-Xwayland-21.1.1-6.el8.x86_64
  yajl-2.1.0-10.el8.x86_64
  yelp-tools-3.28.0-3.el8.noarch

Complete!

Sigh. Each of the two older 8.4 choices at startup screen fails in the same way. So at the moment I have no desktop at all.

Hi,

Not sure whats going on here, but I can see a couple of things worth trying from the error logs

Instructions on clearing sssd can be found here:

Not sure why gdm is failing, but it may be worth seeing if sddm fails as well?

systemctl disable gdm
systemctl enable sddm

Regards Tom.

I’ll resume this tomorrow, or perhaps even Monday. I truly appreciate your responsiveness! It’s Saturday night, you perhaps have other things to do as well. :slight_smile:

I also notice that the virtualbox installation seems to be broken. I had hoped to do the gnome install before attempting the upgrade to 8.5, if nothing else to minimize the number of moving parts.

In any case, I’m calling it a day. More fun tomorrow!

1 Like

This thread seems to be turning into a blog of my attempted change.

If the moderators prefer a different approach – or none at all – please let me know. Having said that, this may be of general interest. I think my configuration is fairly typical, at least for any who started with the RL + Plasma ISO.

FWIW, just a reminded that I attempted to migrate from Plasma to Gnome because of the missing “breeze…” asset that blocked the v8.5 update. I thought that was Plasma-specific – perhaps not.

I’m now doing the suggestion of @tjdoyle of going back to sddm (instead of gdm).

After this change, the system now displays a large virtual keyboard with a black background at startup. This is what I saw before. When I hit “CR”, it shows a (new) login screen. At the top left is a dropdown.

The only dropdown choice that almost works is “Plasma (X11)”. With this selected and a correct password entered, I see a complaint (in red/orange, on a dark blue background) that reads:

The current theme cannot be loaded due to the errors below, please select another theme.

file:///usr/share/sddm/themes/01-breeze-fedora/Main.qml:26:1 plugin cannot be loaded for module "org.kde.plasma.core":

So it appears that neither Plasma nor Gnome will start (for different reasons, apparently).

Just curious - what version of KDE Plasma are/were you using ?

I’m using 5.18 (installed via dnf / the Rocky repos on a standard 8.4 install) and don’t have any issues with it. I did try the latest version via a live Fedora KDE distro and it was very flakey… though I’ve never had Fedora (with Gnome) installed for more than minutes before binning it so 2 variables there. Going to wait a while before moving to a later KDE version - let it settle a bit.

Moved to KDE as got frustrated with the lack of functionality in Gnome , though have access to apps from both now.

KVM/QEMU and VMM have improved a lot recently (as an alternative to VirtualBox) though still a few gotchas particularly with selinux - if you get it working you probably won’t be able to tell you’re in a VM and not the host (performance wise).