How to make cinnamon deskop the only default desktop

Make Cinnamon deskop default on Rocky 9.3

In Rocky 8.8 and 8.7 and centos. The way I make cinnamon the only desktop is run the below and it works. But Rocky 9 its not picking up my cinnamon desktop.

/usr/share/xsessions/cinnamon.deskop
I have removed the gnome deskop files.

But when my system boots up it still loads gnome. Anyone know if this is changed in Rocky 9?

On my Rocky 9 machine, when I select my username but before entering password on the graphical login screen (gdm), in the bottom right hand corner of GDM there is a cog wheel that I click and have Cinnamon set as selected. It always defaults to this once it has been selected.

So i did that and i type my password select cinnamon. Shows me when i last logged in and then returns back to the login screen. In my other builds I don’t have gnome or other desktopn files only cinnamon.desktop so I get no cog and cinnamon logs in by default.

Got that working had network issues. I can now log into cinnamon. But i don’t want the cog. Also why is it showing me Gnome ive removed the gnome.deskop file. Is it looking elsewhere in r9?

The cog is just there as something to click to choose options from. You could replace gdm with lightdm instead - I haven’t done it, but usually on Debian based distros, the Cinnamon install would use lightdm.

I did do it on rocky 8 but did not like the login screen as it was not centered of the screen was off to the left so went back to gdm

/usr/share/gnome-session/sessions/
/usr/share/wayland-sessions/