How do i install latex IEEEtran package in RL9?

How do i install IEEEtran.cls for Latex in RL9?
In other linux, I run:
sudo apt-get install texlive-publishers
but the equivalent in RL9 with dnf does not work.
Thank you for your help

Yes, there is no texlive-publishers package. Not every distro is the same, so package names can vary. That said, there are commands like dnf provides or dnf whatprovides that can help you locate a file in a package, however even with EPEL enabled I do not see any packages that provide that file:

[root@rocky9 ~]# dnf provides */ieeetrans.cls
Last metadata expiration check: 3:40:21 ago on Tue 03 Oct 2023 01:27:54 PM CEST.
Error: No matches found. If searching for a file, try specifying the full path or using a wildcard prefix ("*/") at the beginning.

even if I use IEEEtrans.cls it doesn’t find anything either. This resource: RPM resource tex(IEEEtran.cls) seems to show a similar filename to the one you mentioned, which would hint at the package you need being texlive-ieeetran. This package does exist in Fedora 38, but I don’t see the source rpm appearing here: had it been available, you could download the source rpm for example and then build this to install on Rocky.

Either that, or you can make a package request to see if an EPEL maintainer would add it to the EPEL repository.

One other good resource to use if you cannot find anything is this site: as usually if you cannot find a package, you can search there and generally get an idea of what the package name will be to install on the particular OS of your choice.

1 Like

Yes, you are right, the package is IEEEtran.cls, without the ‘s’.
I’ve put a link to the latex CTAN repository in my initial question.

I thank you for you answer !
Yet… i am still unsure of what the solution is.
Sorry, I’m not that pro in Linux installation topics, I’m just migrating from an Ubuntu environment, so i’m not sure what EPEL is, nor how to solve my problem.
Did you mean to just download a Fedora package (ieeetran_*.rpm) from one of the links you sent and run it?

Maybe a question is: where are all Latex packages stored in Rocky?
Cuz then i can just download the class and paste it there? would that work?

If latex packages exist, then they are downloadable with dnf. As already mentioned you can search to find out what the package name would be. Sadly, as already explained there is no package for Rocky or RHEL that you require. Which means finding the source package and build yourself or asking EPEL to do it. Read more here on how to do that with EPEL: EPEL Package Request :: Fedora Docs

An individual user can drop a LaTeX package to their home directory. (LaTeX tools do search certain paths.)

That (a “source install”) is obviously not as “managed” as installing proper RPM package for (all users of) the system. Request to EPEL is the way.

1 Like

If you want a quick solution you can try the rpm from here:

While it is in general not a good idea to borrow rpms from other distributions, it most probably will work in this case, because Fedora 34 also came with TeXlive 2000, the package is noarch, and RH’s TeXlive is mostly a copy from Fedora’s (minus the packages they deliberately do not build to “lower their support burden”).

Of course packages can depend on other packages and you probably need to borrow some more from this directory.

This is complicated for me, as I’ve never done this.
But i gave it a try and opened a package request, i.e. a bug:

Please check and let me know if i did it right?
Thank you,

I need help again.
They have answered my request to add IEEEtran.cls
Please read in the ticket i opened.
The resolution is:

It is fixed in texlive-extension-20200406-34.el9. Please download and test

Now my problem is when i try in Rocky9 the command:

sudo dnf install texlive-extension
sudo dnf install texlive-extension-20200406-34.el9

it replies: Error: Unable to find a match

So i’m not sure what is wrong?
Please help :slight_smile:

texlive-extension-20200406-34.el9 | Build Info | koji says:

texlive-extension includes many texlive extension which are dropped in RHEL

And has tag: epel9-testing, so the package might/will be in EPEL (but still not in their main repo).

Do you see anything with:

dnf --enablerepo=epel-testing list texlive-extension\*

this is the output when i type the command that you mentioned @jlehtone

$dnf --enablerepo=epel-testing list texlive-extension\*
Extra Packages for Enterprise Linux 9 - Testing - x86_64                                     305 kB/s | 480 kB     00:01    
Last metadata expiration check: 0:00:01 ago on Thu 12 Oct 2023 07:21:55 PM CEST.
Error: No matching Packages to list

The “texlive-extension” seems to be the name of the source package from which many packages are built from. There is no “binary” package with that name.

Do you get anything more with:

dnf --enablerepo=epel-testing list texlive--EE\*

I asked at bugzilla and got the right command:

dnf --enablerepo=epel-testing install texlive-IEEEtran

my next problem is that now it requires a style:

! LaTeX Error: File glossaries.sty not found.

So now my question is: does one have to do the same for every single package that is missing?
or how can i search for a style in this case, it’s not a class.

when i do:
$dnf provides */glossaries\*
many options appear, so not sure whic one to choose.
I am tempted to chose the glossaries-english, but not sure.

how can i know for sure that the install will include the glossaries.sty that i need?

Well you can do:

dnf repoquery -l texlive-glossaries-english

but it doesn’t list that file in that package. I suggest asking EPEL, if they built the package in testing and didn’t include the style that is required, then they need to also include that as well if it depends on it.

You do search for files, whose name starts with “glossaries”. Since you do know the whole name, you can ask with it:

dnf --enablerepo=epel-testing provides */glossaries.sty

btw… i just would like to document for people using Latex with Rocky linux that the best way to download all packages is by using: Miktex

There is even a special RockyLinux release in the downloads area > Linux > RockyLinux:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.