Guacamole issue

Having configured the guacamole software in Rocky8. I can connect by ssh to a remote machine, but the response to character input is very, very slow. I wait several seconds for the echo (unusable). Have you found a problem of the same type or a tip to correct it?

Solved, the problem is related a nginx tip …

Would be good for you to post the solution so that if anyone else experiences it they will know what to do :slight_smile:

Absolutely, the magic solution was add the line

proxy_buffering off;
in the record defining the service on the nginx side
location /guacamole {
proxy_pass http://guacamole;
proxy_buffering off;
proxy_http_version 1.1;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header Upgrade $http_upgrade;
proxy_set_header Connection $http_connection;
access_log off;

Anyway, solved that, my problem is now understanding why access with a pair of RSA keys (without password) is not working. :thinking:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.