Getting error while updating the corosynclib-3.1.8-1.el9.x86_64 f

Getting error while updating the package from corosynclib-3.1.7-1.el9.x86_64 to corosynclib-3.1.8-1.el9.x86_64

yum update
Extra Packages for Enterprise Linux 9 openh264 (From Cisco) - x86_64 3.4 kB/s | 2.5 kB 00:00
Prod Packages - x86_64 34 kB/s | 8.6 kB 00:00
Rocky Linux 9 - BaseOS 2.3 MB/s | 2.2 MB 00:00
Rocky Linux 9 - AppStream 4.5 MB/s | 7.9 MB 00:01
Zabbix Official Repository - x86_64 415 kB/s | 344 kB 00:00
Zabbix Official Repository (non-supported) - x86_64 2.0 kB/s | 1.1 kB 00:00
Zabbix Official Repository (Agent2 Plugins) - x86_64 2.8 kB/s | 1.6 kB 00:00
Error:
Problem: cannot install both corosynclib-3.1.8-1.el9.x86_64 from appstream and corosynclib-3.1.7-1.el9.x86_64 from @System

  • package corosync-3.1.7-1.el9.x86_64 from @System requires corosynclib(x86-64) = 3.1.7-1.el9, but none of the providers can be installed
  • cannot install the best update candidate for package corosynclib-3.1.7-1.el9.x86_64
  • problem with installed package corosync-3.1.7-1.el9.x86_64
    (try to add ‘–allowerasing’ to command line to replace conflicting packages or ‘–skip-broken’ to skip uninstallable packages or ‘–nobest’ to use not only best candidate packages)

Looks like you might just have BaseOS and AppStream: do you also need HighAvailability?

Can you try:

dnf list corosynclib

Pls find the below output

dnf list corosynclib
Extra Packages for Enterprise Linux 9 openh264 (From Cisco) - x86_64 3.7 kB/s | 2.5 kB 00:00
Prod Packages - x86_64 28 kB/s | 8.6 kB 00:00
Rocky Linux 9 - BaseOS 2.0 MB/s | 2.2 MB 00:01
Rocky Linux 9 - AppStream 4.3 MB/s | 7.9 MB 00:01
Zabbix Official Repository - x86_64 388 kB/s | 344 kB 00:00
Zabbix Official Repository (non-supported) - x86_64 1.6 kB/s | 1.1 kB 00:00
Zabbix Official Repository (Agent2 Plugins) - x86_64 2.8 kB/s | 1.6 kB 00:00
Installed Packages
corosynclib.x86_64 3.1.7-1.el9 @appstream
Available Packages
corosynclib.i686 3.1.8-1.el9 appstream
corosynclib.x86_64 3.1.8-1.el9 appstream

I would do:

dnf remove corosynclib
dnf install corosynclib

I’m guessing the 3.1.7 was installed outside of the Rocky repositories and is causing a conflict. So you need to get your system in a sane state ideally by removing it, and then installing it again if it is needed.

Yes, the output of dnf list implies you could do a simple upgrade, but it’s not working.

If i do the re-installation again I need to configure the Cluster.

It’s there any alternative way or I need to wait until this issue get fixed in Rocky repo

This isn’t a “rocky repo” problem. I don’t know how this was the conclusion that we came to, given that “corosynclib” is in AppStream and CRB, and “corosync” itself is in HighAvailability. It appears you have installed corosync from high availability or another applicable repo and did not keep it enabled.

Enable the highavailability repository and you’ll likely be able to update.