Fail to run xfce after upgrade to Rocky 8.5

Machines installed Centos and a few months ago upgraded to Rocky without problems.

After the recent upgrade to 8.5 (ie yesterday, today) a user trying to login and expecting to run Xfce - cannot login. After typing the password there is a pause of about 15 seconds and the list of users is shown again.

I see in the release notes that there has been some work here …

it referrs to /etc/accountsservice/user-templates/standard & /var/lib/AccountsService/users/user-name but playing with these does not do what it should.

The accountservice seems to be about setting default session. Thus unrelated.

Have you looked at logs?

sudo journactl -xe
sudo less /var/log/messages
sudo less /var/log/secure

Do the other sessions (than xfce) operate normally?
Was there any issues on the dnf upgrade?


I am having the same problem. I dnf upgraded a RL 8.4 to 8.5, and there weren’t any warnings.

In /var/log/messages, I saw this:

Nov 18 22:40:55 morris gdm[1768]: Gdm: GdmDisplay: Session never registered, failing
Nov 18 22:40:57 morris systemd-logind[1324]: Session 10 logged out. Waiting for processes to exit.
Nov 18 22:40:57 morris systemd[1]: session-10.scope: Succeeded.
Nov 18 22:40:57 morris systemd-logind[1324]: Removed session 10.
Nov 18 22:40:58 morris org.gnome.Shell.desktop[9983]: The XKEYBOARD keymap compiler (xkbcomp) reports:
Nov 18 22:40:58 morris org.gnome.Shell.desktop[9983]: > Warning:          Unsupported maximum keycode 569, clipping.
Nov 18 22:40:58 morris org.gnome.Shell.desktop[9983]: >                   X11 cannot support keycodes above 255.
Nov 18 22:40:58 morris org.gnome.Shell.desktop[9983]: Errors from xkbcomp are not fatal to the X server

There were other messages from gdm, but didn’t seem relevant. The entire session log from /var/log/messages is here:


A bit more digging and I found in /var/log/messages:

/usr/libexec/gdm-wayland-session[119565]: /usr/libexec/Xorg.wrap: Only console users are allowed to run the X server

I created the file /etc/X11/Xwrapper.config with content:

allowed_users = anybody

and it all works nicely.

I had been fiddling so I do not know if any of the stuff below is also needed.

I note:
This talks about /var/lib/AccountsService/users/user-name
This contains:



So, the question is what should Xorg.wrap contain ?

Is it because xfce uses X and not Waylan ?

I run MATE on Rocky Linux and the same happened to me. I fixed it by typing this on a Terminal:

sudo systemctl set-default

Hope that helps.