Trouble logging in after experimenting with several desktop managers

I wanted to test some vncserver configurations using several different desktop managers (Wayland default, Gnome Classic, Gnome Xorg, XFCE, Plasma Wayland, and Plasma X11). Maybe because I was switching back and forth several times, I got to a point where when I entered my user credentials, it just bounced me back to the same login prompt again - well, that was depending on the desktop manager I was using - XFCE and Gnome just brought me back to the logon prompt again - with Plasma the screen would go blank
I didn’t have a problem logging in as root - only when I used my regular user account.
I found if I disabled gdm, I would get a command prompt login, and running ‘startx’ after logging in Gnome and XFCE would launch the desktop manager, even with my regular user account.
Maybe I should just reinstall the OS again and start over, but I’d really like to know what’s going on and how to fix it, if possible.
Any suggestions?

You should be able to switch between the supported Gnome (classic, wayland, xorg) without damaging your system, but if you’re going to install unsupported software, you should really have a roll-back plan, so you can do clean uninstall and put everything back how it was…

Both KDE Plasma and XFCE are in the EPEL repos.

try to delete (as root) the .Xauthority of the user.

Yes, but unfortunately packages in epel is not supported.

Thanks. That got me back into gnome classic and gnome xorg.

KDE and XFCE are also both available on the Rocky Linux website as Live images - I don’t think your assertion that XFCE and KDE “aren’t supported” is accurate.

And they are using the packages available from the EPEL repository. The Rocky team provide the Live ISO, that is all. If something doesn’t work with KDE, then EPEL are effectively responsible for any regressions or problems caused by those packages. They are not maintained by the Rocky team.

You can come here of course for help, and the community may be able to help if they have experienced a similar problem to you. But there are no guarantees.

I have no expectation of any “guaranteed” support on a voluntary (and free) community support forum. There’s a lot of cumulative knowledge on this forum of people using Rocky Linux - I post things ‘hoping’ somebody has seen similar issues before, but if not, that’s the breaks.
I am in complete agreement with your last sentence.

1 Like

Suggest you take the display manager out of the picture by doing “systemctl set-default=multi-user.target”. You may have to do this from an alternate console if you can’t get to a command prompt. Then use startx to bring up the desktop du jour. You can control which desktop you get by editing the file ~/.xinitrc. My .xinitrc looks like:
[dave@bend ~]$ cat .xinitrc
exec /usr/bin/mate-session

You can switch back to starting in graphical mode once you get all of the various desktops to behave when started with startx. I prefer to have my systems come up in multi-user mode and then do startx for a variety of reasons. You may find that you have a configuration problem that is preventing the problematic desktops from starting and that will be easier to diagnose when you do a startx from the CLI.

I tried the XFCE live image and that worked great for getting XFCE to work nicely - I guess it made all the necessary tweaks to make it work correctly.
I have some VNC questions, but that’s better for a new thread.
Thanks for the feedback.