Error yum update when execute update

Hello everyone, and I haven’t been able to get the updates for some time.

It always reports this error to me :slight_smile:

[root@rlinux ~]# yum update
Extra Packages for Enterprise Linux 9 - x86_64                                                              2.5 MB/s |  21 MB     00:08    
Extra Packages for Enterprise Linux 9 openh264 (From Cisco) - x86_64                                        2.4 kB/s | 2.5 kB     00:01    
Rocky Linux 9 - BaseOS                                                                                      976 kB/s | 2.2 MB     00:02    
Rocky Linux 9 - AppStream                                                                                   2.0 MB/s | 7.9 MB     00:03    
Rocky Linux 9 - CRB                                                                                         1.8 MB/s | 2.4 MB     00:01    
Rocky Linux 9 - Extras                                                                                       23 kB/s |  15 kB     00:00    
Rocky Linux 9 - Plus                                                                                        7.2 kB/s | 4.5 kB     00:00    
Errore: 
 Problema 1: cannot install both kernel-tools-libs-5.14.0-427.16.1.el9_4.x86_64 from baseos and kernel-tools-libs-5.14.0-362.24.1.el9_3.0.1.x86_64 from @System
  - package gnome-applets-3.40.0-1.el9.x86_64 from @System requires libcpupower.so.0()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package kernel-tools-libs-5.14.0-362.24.1.el9_3.0.1.x86_64
  - cannot install the best update candidate for package gnome-applets-3.40.0-1.el9.x86_64
 Problema 2: package gnome-flashback-3.40.0-2.el9.x86_64 from @System requires gnome-applets(x86-64), but none of the providers can be installed
  - package gnome-applets-3.40.0-1.el9.x86_64 from @System requires libcpupower.so.0()(64bit), but none of the providers can be installed
  - package gnome-applets-3.40.0-1.el9.x86_64 from epel requires libcpupower.so.0()(64bit), but none of the providers can be installed
  - cannot install both kernel-tools-libs-5.14.0-427.16.1.el9_4.x86_64 from baseos and kernel-tools-libs-5.14.0-362.24.1.el9_3.0.1.x86_64 from @System
  - package kernel-tools-5.14.0-427.16.1.el9_4.x86_64 from baseos requires kernel-tools-libs = 5.14.0-427.16.1.el9_4, but none of the providers can be installed
  - package kernel-tools-5.14.0-427.16.1.el9_4.x86_64 from baseos requires libcpupower.so.1()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package kernel-tools-5.14.0-362.24.1.el9_3.0.1.x86_64
  - cannot install the best update candidate for package gnome-flashback-3.40.0-2.el9.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
[root@rlinux ~]# 

Hi,
try to install kernels-tools

dnf provides */libcpupower.so\*

It says “kernel-tools-libs”. The el9_3 had libcpupower.so.0. The el9_4 has libcpupower.so.1.

The “gnome-applets” is from EPEL. It depends on el9_3’s version of the lib. EPEL has to rebuild “gnome-applets” for el9_4.


Remove gnome-applets. Then other packages may update. Reinstall gnome-applets once EPEL has a new version.

Hi , I did what you told me and deleting the package upgraded by downloading over 1gb . Thanks to everyone for the directions! .