Error when running Yum Update

When running “yum update” or “dnf update” - Rocky 9.1 to 9.4 produces this warning and will not proceed.

Problem: cannot install both initscripts-10.11.6-1.el9.x86_64 from baseos and initscripts-10.11.5-1.el9.x86_64 from @System

  • package network-scripts-10.11.5-1.el9.x86_64 from @System requires initscripts(x86-64) = 10.11.5-1.el9, but none of the providers can be installed
  • cannot install the best update candidate for package initscripts-10.11.5-1.el9.x86_64
  • problem with installed package network-scripts-10.11.5-1.el9.x86_64
    (try to add ‘–allowerasing’ to command line to replace conflicting packages or ‘–skip-broken’ to skip uninstallable packages or ‘–nobest’ to use not only best candidate packages)

Bypassed error by adding
exclude=network-scripts* initscripts*

to /etc/yum.conf

and install can now be updated to 9.4 and boots fine but is it ok to leave it like this?


yum repolist
repo id repo name
appstream Rocky Linux 9 - AppStream
baseos Rocky Linux 9 - BaseOS
extras Rocky Linux 9 - Extras

Kernel Info:
Linux vmhost2 5.14.0-427.18.1.el9_4.x86_64 #1 SMP PREEMPT_DYNAMIC Mon May 27 16:35:12 UTC 2024 x86_64 x86_64 x86_64 GNU/Linux

i don’t have any other repo’s enabled (epel is installed but all enabled=0)

These are the currently installed packages:

Help please and thank you.

It is likely that “network-scripts” are no longer supported. I don’t have this package or “initscripts” installed on my system. I migrated my old network scripts to the new networkmanager “ini” file format a while back in anticipation of this eventuality. I think if you look in /etc/sysconfig/network/ there is a file that explains the migration process as this has been anticipated for a few years.