Does RL 9.3 support Docker?

Having recently done Docker installs successfully on Rocky 9.2, I’ve spent 2 or more days unsuccessfully with 9.3…

The error I’m down to now is this:

docker: Error response from daemon: failed to create task for container: failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: can't copy bootstrap data to pipe: write init-p: broken pipe: unknown

Docker does seem to start OK but when trying to run hello-world, I get the above.

Most other references to this error talk about kernel issues or firewalld or selinux.

I have disabled firewalld and set selinux to permissive but still cannot resolve this error. So I’m left with possible kernel issue or something else.

Has anyone been successful with Docker on 9.3?

And to those that say use Podman, I need Docker Swarm - works on 9.2.


  • I am no expert on docker ce but this is a working example on my test RL9.3, it works after OS upgrade from 9.2.
  • May be the user need to be in docker group ?
[me@rocky9t01a ~]$ cat /etc/redhat-release
Rocky Linux release 9.3 (Blue Onyx)
[me@rocky9t01a ~]$ id me
uid=1000(me) gid=1000(me) groups=1000(me),10(wheel),983(docker)
[me@rocky9t01a ~]$  docker run hello-world
Unable to find image 'hello-world:latest' locally
latest: Pulling from library/hello-world
719385e32844: Pull complete
Digest: sha256:c79d06dfdfd3d3eb04cafd0dc2bacab0992ebc243e083cabe208bac4dd7759e0
Status: Downloaded newer image for hello-world:latest

Hello from Docker!
This message shows that your installation appears to be working correctly.

To generate this message, Docker took the following steps:
 1. The Docker client contacted the Docker daemon.
 2. The Docker daemon pulled the "hello-world" image from the Docker Hub.
 3. The Docker daemon created a new container from that image which runs the
    executable that produces the output you are currently reading.
 4. The Docker daemon streamed that output to the Docker client, which sent it
    to your terminal.

To try something more ambitious, you can run an Ubuntu container with:
 $ docker run -it ubuntu bash

Share images, automate workflows, and more with a free Docker ID:

For more examples and ideas, visit:

[me@rocky9t01a ~]$ docker run -it ubuntu bash
Unable to find image 'ubuntu:latest' locally
latest: Pulling from library/ubuntu
5e8117c0bd28: Pull complete
Digest: sha256:8eab65df33a6de2844c9aefd19efe8ddb87b7df5e9185a4ab73af936225685bb
Status: Downloaded newer image for ubuntu:latest
root@b1a13c2e676c:/# uname -a
Linux b1a13c2e676c 5.14.0-362.8.1.el9_3.x86_64 #1 SMP PREEMPT_DYNAMIC Wed Nov 8 17:36:32 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux
root@b1a13c2e676c:/# exit
[me@rocky9t01a ~]$

Thanks Tiyang.

Good to know… Still something on my end then…

Yes, it’s definitely in the docker group.

My only unusual setup is I configured the Docker data-root to a dedicated mount. Docker certainly generated its heap of folders and files in the new path so I assume that’s OK…

Maybe I try setting back to default… thanks again…

And after standard install still fails with the same error…

I don’t know the root cause, but have you tried to google the exact error message ?’t+copy+bootstrap+data+to+pipe%3A+write+init-p%3A+broken+pipe%3A+unknown&rlz=1C1GCEA_enUS1010US1010&oq=docker%3A+Error+response+from+daemon%3A+failed+to+create+task+for+container%3A+failed+to+create+shim+task%3A+OCI+runtime+create+failed%3A+runc+create+failed%3A+unable+to+start+container+process%3A+can’t+copy+bootstrap+data+to+pipe%3A+write+init-p%3A+broken+pipe%3A+unknown&gs_lcrp=EgZjaHJvbWUyBggAEEUYOTIGCAEQRRg60gEKMTQzMDBqMGoxNagCALACAA&sourceid=chrome&ie=UTF-8

of course… I spent 2 days trying all sorts of things… but good news… I just reinstalled Rocky 9.3 from scratch, installed docker as per this
and it all worked first time… but that seems exactly the same as what I did the first time which was this

The only difference this time was I did not select a security profile during Rocky install. Maybe that was it?

thanks for your input!

Glad your issue got resolved, This could be another time saver tip for another.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.