Centos 8 Stream - end of life ----> migrate to Rocky

Centos Stream 8 is done, no more updates are available. Will the “migrate2rocky” just work? Or are there some gotcha’s I need to be aware. Thanks

From a quick forum search: Search results for 'migrate2rocky order:latest' - Rocky Linux Forum

Some people have been successful, some have encountered issues. So your mileage may vary. Might even be worthwhile considering taking a backup of your data, and just making a clean install of Rocky and restore data, instead of using a migration that may or may not work.

Thanks for your reply. I am wanting to avoid a clean install if at all possible so my existing setup is retained. I use Samba, remote desktop and other services to manage and use the server. A clean install will take a long time.

I was just curious if the migrate2rocky script is a 50-50 proposition or more likely than not, I will have little problem. My centos 8 Stream installation is not modified.

I would say it’s more successful than not. I’ve not used it personally since I never had any CentOS systems to convert. If you are mostly using standard packages from repositories like CentOS or EPEL, then I expect it shouldn’t be too problematic. If using some exotic repositories that aren’t common or packages installed outside of repositories (manually downloaded), then problems could occur.

If it’s a VM, make a snapshot before starting the migration. I would also ensure a backup of data just in case.

All dataon these servers is always backed up, so worse case I have to do a clean install and go through the pain. And even with a system backup available, I can’t go back to Centos anyway. I am choosing Rocky because of the history and evolution from Centos. I have two Centos servers. I thought about AlmaLinux, but again Rocky seems to be a better fit. And it has a lot of backing.

1 Like

@pajamian would need to chime in. The migrate2rocky script may need modifications to deal with the end of life of CentOS Stream 8. We recently synced everything from their vault to our vault for this in case vault.centos.org would not work.

1 Like

At the moment migrate2rocky should work for migrations from CentOS Stream 8 if your CentOS Stream repos point to the appropriate repos in vault.centos.org or to our vault mirror in dl.rockylinux.org. I will be updating migrate2rocky so it will automatically find the vault repos in order to perform the migration but simply have not had the time to do so yet.

One additional note: CentOS vault has limited bandwidth so it is preferred that you use our vault mirror at Index of /vault/centos/8-stream/ for this.

1 Like

I tried to run the script before seeing your post on the “vault” - and sure enough it failed:

./migrate2rocky.sh -r
migrate2rocky - Begin logging at Wed 12 Jun 2024 03:54:39 PM CDT.

Removing dnf cache
Preparing to migrate CentOS Stream 8 to Rocky Linux 8.

Determining repository names for CentOS Stream 8.Error: Failed to download metadata for repo ‘appstream’: Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

Failed to fetch info for package apr-util-ldap.x86_64.

An error occurred while we were attempting to convert your system to Rocky Linux. Your system may be unstable. Script will now exit to prevent possible damage.

A log of this installation can be found at /var/log/migrate2rocky.log"

I need help pointing my current CentOS stream repos to ‘index of /vault/centos/8-strem/’ …
thanks for helping me get on Rocky!

You need to edit one or more of the .repo files is /etc/yum.repos.d/. You want to find the appropriate file and the appropriate repository in that file then comment out any baseurl and mirrorlist lines and add a new baseurl line pointing to the new repository location. To find the repository location look for the directory that contains a repodata directory, so for example if you browse to https://dl.rockylinux.org/vault/centos/8-stream/BaseOS/x86_64/os/ you will see repodata in the listing, so that means that you want to use https://dl.rockylinux.org/vault/centos/8-stream/BaseOS/x86_64/os/ for the baseurl of the baseos repo.