"Cannot open /dev/vmmon: No such file or directory" error when powering on a VM - Rocky Linux

Hi everyone!
First of all, sorry if I say something wrong, my English level is basic and I’ve learned it in the most part by myself.

I use a Rocky Linux 8.7 (Green Obsidian) x64 in dual boot with Windows 11 x64 both of them with Secure Boot Enabled and in AHCI Mode on BIOS. Virtualization it’s also enabled on BIOS.
It’s an Acer Nitro 5 with Intel Core i5-8300H @4.00Ghz, 8GB DDR4 RAM, SSD512GB NVME and Nvidia GeForce GTX 1050 Mobile.
I had the problem at Rocky Linux so, lets focus on it.

The problem
I’ve installed VMWare Player 17 with success but when I try to open a virtual machine it shows me the following two messages:

  1. Error: Could not open /dev/vmmon: No such file or directory.
    Please make sure that the kernel module ‘vmmom’ is loaded.
    When I click to close or in OK it shows me the message two bellow.

  2. Error: Failed to initialize monitor device.
    When I click to close or in OK it closes the WMWare Player 17.

The possible solution I tryed but it didn’t work out
I’ve found this link and try to follow the steps: https://kb.vmware.com/s/article/2146460

  1. Terminal comand:
    openssl req -new -x509 -newkey rsa:2048 -keyout MOK.priv -outform DER -out MOK.der -nodes -days 36500 -subj “/CN=VMware/”

When I run it on terminal it shows me:
Generating a RSA private key
…+++++
…+++++
writing new private key to ‘MOK.priv’
-----

  1. Terminal comand: sudo /usr/src/linux-headers-uname -r/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n vmmon)

When I run it on terminal and type my password it shows me:
sudo: /usr/src/linux-headers-4.18.0-425.3.1.el8.x86_64/scripts/sign-file: command not found

After that, its impossible tu run the other following commands, none of them are working.
I hope some friend could help me here.
Thanks any way and I wish the best for us all, greetings!

How did you install it, and are you sure it’s supported on Rocky?

If you just want to sign a module, you can try

/usr/src/kernels/$(uname -r)/scripts/sign-file --help