Cannot access XRDP or login with GUI using NIS account

I setup a new NIS domain between 2 servers (NIS master - mst; NIS client - clint). The NIS domain account can ssh login to the client - clint. But it could not login to clint through GUI desktop. Even it could not login through XRDP. When doing so, it just showed a black screen and no further response.

Using clint local account, I could login to clint through both GUI desktop and XRDP. Also, I checked the NIS domain by “yptest” and “ypwhich -x” and both showed normal. I don’t know what I have missed. Could you please give some advice to me? Thanks!

The fact you get a black screen probably means the login has worked - otherwise you would get an authentication error and be returned to the login screen ?

Are there any other differences between the local account and the NIS accounts - e.g. where are the home directories for the local/NIS accounts ?

Yes, at the same time, I setup a NFS service with the same NIS master server - mst. And I export home folders to the clint as the home folders (by mount point) of the NIS accounts; while I moved the original home folder of the local account to another location (/local_home/xxx) and changed the path of the home folder stated in the passwd file with this new location.

So does it work for a NIS user that has a home directory locally on clint ?

The NIS user can login the clint through remote desktop only when I set all 3 following things (actually create another local account in clint):

  1. Copy the content of the NIS user home folder from /home to /local_home/
  2. Add the NIS user info. in the /etc/passwd file in clint.
  3. Create the NIS user info. in the /etc/shadow in clint.

If only do the first 2 things, the NIS user still didn’t work to use the remote desktop in clint. I guessed there is some problem for using NIS password and shadow in GUI, but the content inside the home folder is fine for the remote desktop. So, what should it be related to?

What happens if you only do the first item in your list (Copy the content of the NIS user home folder from /home to /local_home/) ? - you will have to make sure NIS user picks up their home directory from /local_home/

Yes, it worked when carrying the first item and changing the home location at the NIS server to /local_home/.

That seems to suggest something strange with the home directories provided over the network ?

How are you exporting and mounting the the home directories ?

I export the following 3 folders to 2 ranges of IPs.
exports

For setting the user quota, I created a separate partition for the home folders. And I mounted it to a folder created (/CADHOME-HOME_DIR) in the fstab file as follows:

/dev/mapper/rl_padnfs03-CADHOME–HOME_DIR /CADHOME-HOME_DIR xfs defaults,uquota 0 0

Then, I created a symbolic link pointing to this mounted folder.

lrwxrwxrwx. 1 cadadmin cadadmin 17 May 16 23:11 /exports/home → /CADHOME-HOME_DIR

I am not sure whether there is any problem.

Is the NIS user under their home directory quota ?

No, it is “cadadmin”.

Even another NIS account with 6G quota also didn’t login normally.

Thanks james-p! Finally, I could use the GUI service when remount my NFS home folder as follows:

Thank you very much!