Calbre Ebook Management and Pipewire Sound Server

Hai all, I just installed and used Rocky linux 8.3 RC1 two day ago. I have questtion

  • How to install Calibre in Rocky Linux 8.3 RC1?
  • How to completely rfemove pulseaudio, I want to install and use pipewire?
    I have done searching on the internet and I add rpmfusion repo for centos 8 in rpm fusion webstite
    Configuration - RPM Fusion
    but still doesn’t solved my problem.

Hi @afiadi ,


I know, I already there before ask to this forum. But thank you for your solution. I still can’t do it because my Rocky Linux is installed di hdd laptop. I won’t mess up my Rorcky linux if I go to the arch linux documentation and do install pipewire.
Can i just install pipewire and pulseaudio automatically replaced by pipewire after that instalation procedure?
I’m noob, I actually don’t know what will I’m doing, I need details step by step install pipewire in Rocky Linux 8.3 RC1.
In Arch Wiki doesn’t clearly mention step by step installation pipewire if pulseaudio already exists.
Can you help me doing that?
Thanks In Advance.

About Calibre, in Fedora calibre can installed from rpmfusion repo, why in rmpfusion for centos 8 there is no Calibre packet. Is it safe to install calibre just copas this command to my terminal Rocky Linux?
sudo -v && wget -nv -O- | sudo sh /dev/stdin
FYI my Rocky Linux doesn’t have python3 installed.

No problem together will be written Pipewire replacement’s guide.
I’ve do a small guide for you and the rest of the people who wants to set up Calibre in your system.

When I have a bit of time, I will help you!


1 Like

Thank you so much, Calibre is installed in my Rocky Linux. :heart_eyes: :pray:
But when I’ve tried to install pipewire I type this and this is the result:
[afiadi@rockylinux ~]$ sudo dnf install pipewire
[sudo] password for afiadi:
Last metadata expiration check: 0:19:41 ago on Kam 13 Mei 2021 02:57:38 WIB.
Package pipewire-0.3.6-1.el8.x86_64 is already installed.
Dependensi terselesaikan.
Tidak ada yang dilakukan.

and I tried to continue install pipewire-docs, pipewire-alsa, pipewire-pulse and pipewire jack and this is the result:
[afiadi@rockylinux ~]$ sudo dnf install pipewire-docs pipewire-alsa pipewire-pulse pipewire-jack
Last metadata expiration check: 0:21:39 ago on Kam 13 Mei 2021 02:57:38 WIB.
No match for argument: pipewire-docs
No match for argument: pipewire-alsa
No match for argument: pipewire-pulse
No match for argument: pipewire-jack
Galat: Unable to find a match: pipewire-docs pipewire-alsa pipewire-pulse pipewire-jack

in my current repo my Rocky Linux can’t find all those package
This is my repo Rocky Linux:
[afiadi@rockylinux ~]$ dnf repolist
id repo nama repo
appstream Rocky Linux 8 - AppStream
baseos Rocky Linux 8 - BaseOS
epel Extra Packages for Enterprise Linux 8 - x86_64
epel-modular Extra Packages for Enterprise Linux Modular 8 - x86_64
extras Rocky Linux 8 - Extras
rpmfusion-free-updates RPM Fusion for EL 8 - Free - Updates

How can I solved that?because in my fedora 34 I’ve already installed pipewire.


1 Like

I think is not prepared Pipewire to use in Rocky Linux yet. Fedora 34 is comming by default.

You can see this packages I have installed on Fedora:

rpm -qa |grep pulse

Pipewire packages too

rpm -qa |grep pipew

However, in Rocky:

And if you try to remove pulseaudio, you will remove almost all system. So, you have to wait… or compile and replace Pipewire.

Siap, Oke I see, fedora 34 was prepared to use pipewire for default audio servicce server, Yes pipewire and jack audio server working flawlessly in my fedora 34. Thanks you very much for your sugestion and explanation :heart_eyes: :pray:, I will wait Rocly linux use kernel ready for use pipeweire. In my ears pipewire is much clean and musical sounding. FYI jack audio server in my Rocky Linux isn’t working.

Very different package pipewire in Rocky Linux and pipewire in Fedora 34. I’d rather have to wait for it to be available and ready for use in my Rocky Linux. Thanks for yout help :pray:

Yes, Fedora 34 with Pipewire is awesome. You can use OBS Studio with Wayland to resolving these problems OBS does have before with Wayland.

Yes, Rocky Linux maybe takes more time to introduce new versions of Pipewire, maybe you can download srpm, adapt it and install it to try if you can use Pipewire with Rocky.

1 Like