Cailbre on Rocky Linux 8.7


Migrated to Rocky Linux 8.7 from latest Centos 8.5.2111.

Calibre throws the following and is not working at all

Using python executable: /usr/bin/python3
Your system has GNU libc version 2.28. The calibre binaries require at least version: 2.31 (released on 2020-02-01). Update your system.

glibc 2.28 is the latest version on RL8 AFAIK. I don’t want to upgrade to RL9 because all other software work flawlessly on RL8 and I am not sure they will work on 9.

Is there a way to (re)install calibre on RL8?


Hello @msurg,
Unfortunately, Calibre absolutely requires the 2.31 glibc version. My guess is that you were using an older install of Calibre on your CentOS 8.5.2111 machine, and therefore never ran into the dependency issue there. In order to get the newer glibc, you would have to upgrade your system to RL 9.x (actually reinstall and restore any files you need from a backup, as there is no “upgrade” path to 9.1 from RL 8.x). The only possible way you might be able to get Calibre installed is if you can find an older version of the software that does not require the new glibc version. In my brief search, I did find this:

Good Luck!!

An option is (This is the link to Calibre on flathub):

Flatpak on Rocky Linux Quick Setup :

Version 4.23 worked on RL8.

Thank you