Bug?: Default user login behaviour changed for the Rocky Linux 9 Generic Cloud Image

Hi,
At the begining of the month I downloaded the Rocky Linux generic cloud image (qcow2) from here. And I successfully started the image using:

virt-install --name=rocky --ram=4096 --vcpus=8 \
--disk Rocky-9-GenericCloud-Base.latest.x86_64.qcow2 \
--pxe --noautoconsole \
--os-variant rhel9.0

Today I decided to download the latest version, however when I tried the same command followed up by log in with the rocky user it asked for a password, before it was allowing me to login without a password, downloaded a few versions back and found out that the rocky user login works wihtout a password for this one, but for anything newer it asks for a password.

I am connecting to the VM via virsh console rocky, then when it gets to this part:

Rocky Linux 9.4 (Blue Onyx)
Kernel 5.14.0-427.13.1.el9_4.x86_64 on an x86_64

Activate the web console with: systemctl enable --now cockpit.socket

localhost login:

I enter rocky and it should allow me to login without a password.

Is this an intentional change/bug fix that changed the behaviour, if so where should I be checking for any such changes, what user/password should I enter for the newer releases?

The behavior in the previous image was a bug. With generic cloud, you need to be passing in a cloud init configuration file that adds an ssh public key or configures a password.

Is there a place that I can monitor for changes within the Rocky Linux images/setup process/etc?

1 Like