ARM (RbPi 4b) wake on GPIO 3

It seems like the wake-on-gpio-pin-3 is not working with RL-9.2 on the Raspberry Pi 4b at least. Information on other OSes seem to mention patching certain fields in EEPROM boot loader, a bin-file located In /boot. The only bin- file I find there is boot code.bin, but I don’t seem to find the appropriate fields in this file.
Shutdown is supposed to put the RbPi in halt-mode with power still applied - unless power-off is specified. In this mode, the RbPi is able to respond to GPIO-3 pull-down/release. But if in power-off mode, only by pulling down and releasing “GLOBAL_EN”.
The functionality of the shut-down state seems to have been changed from RbPi 3 to RbPi 4, and there has been some developments in this exact field since the launch of the RbPi 4.
Is there any information on how to configure and reprogram the boot EEPROM on ARM under RockyLinux?

Turns out this may be caused by an early model of the RbPi 4b. Later boot EEPROM firmware has reversed this behaviour. The fix is to upgrade the boot firmware.
I have not found any straight-forward way of doing this under Rockylinux. Probably the easiest way is to prepare a flashcard as described in this git path: GitHub - raspberrypi/rpi-eeprom: Installation scripts and binaries for the closed sourced Raspberry Pi 4 EEPROMs, under the heading “Reset to factory defaults”.
I did not manage to do this under MacOS, but Windows worked. I don’t have GUI running on any Linux installation, but that might work as well.
After successful boot firmware upgrade I reinserted the RockyLinux SD and everything works as expected.
If you need to tweak the boot firmware settings “further”, you might possibly need to prepare a RaspberryPi OS SD card, I have not found utilities in the RockyLinux repositories for manipulating the boot firmware (or GPIO pins for that matter).