Archive support in xfce version


I installed version 8.5 xfce and I can’t manage the archives in the file manager. Thunar tells me that I don’t have any software installed to manupulate archives even though thunar-archive plugin is present.
I tried to install xarchiver but I can’t find it in any repository.
What can I do?
I don’t want to install peazip because it is slow and unresponsive.


I don’t know anything about the thunar-archive plugin, but most gui archive managers are merely a front-end for a command-line archive handling program.

So if you have a gui archive manager installed but don’t have, for example, the zip rpm installed, then when you try to examine a zip archive it won’t work because the zip program that’s being called for in the background doesn’t exist.

What’s the exact wording of the error message that you’re getting? That will probably provide a clue as to what’s missing.


The message I received was displayed in a popup window and was not very informative (your answer helped a lot):

“Failed to extract files.
No suitable archive manager was found”

When I installed an archive manager, the right-click option worked as expected.

$ sudo dnf install file-roller


Edit - I found a list of alternatives to xarchiver by searching:

$ dnf search archive