ACPI BIOS errors running installer from USB

Are there known issues with the ISO installers on certain x86_64 systems?

Similarly to this rather old post, I get an ACPI BIOS error when running the Rocky 8 and 9 installers from USB.

The error is as follows:

ACPI BIOS Error (bug): could not resolve symbol [_SB.PC00.TXHC.RHUB.SS01], AE_NOT_FOUND (20211217/dswload2-162)
ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20211217/psobject-220)

This appears twice followed by some complaints about missing modules:

dracut-pre-udev[599] anaconda-modprobe: Module cramfs not found
dracut-pre-udev[599] anaconda-modprobe: Module floppy not found
dracut-pre-udev[647] modprobe: ERROR: could not insert ‘edd’: No such device
dracut-pre-udev[599] anaconda-modprobe: Module sha256 not found

The installer appears to run after this. Media check is OK and it gets as far as Finished: Terminate Plymouth Boot Screen but then hangs on a blank screen.

I flashed my USB as per the recommended approach, using Fedora Image Writer on macOS. Also I tried dd on Mac with the same result.

Worth noting that I get the exact same error with Alma Linux 9, and also CentOS 8 Stream. However I was able to install CentOS Linux 7 without a hitch. I’m wondering if this being considerably older is meaningful here.

I don’t known enough about BIOS and chipsets to give useful information here, but the BIOS main screen reports BIOS version ADLNV104. The processor is Intel N95 (AlderLake ULX).

I don’t hold out much hope getting support from the Mini PC manufacturer/distributer. Is there anything I need to know about running these installers that I’ve not already tried?

Help greatly appreciated.

FWIW I get similar ACPI Error: AE_NOT_FOUND errors when I boot up.

I am running Rocky 8.x on a 10 year old Dell business laptop.

I have researched this quite a bit, I my understanding is that these errors are due to older BIOS and chip sets. But they cause no actual issues.

In 2 years of booting up daily with these errors, I have never had any issues with Rocky on my laptop.

I have not had the dracut errors though.

Thanks for the reply. So perhaps the BIOS errors are a red herring then. I can live with that!

Modules not being found sounds bad. I’ll peruse this line of enquiry.

Would be great if someone from Rocky could help establish if I can run this OS. Machine vendor has said they’ve only tested with Ubuntu (mainly Windows customers), so I’m going to try Ubuntu shortly. Shame if I can’t run Rocky because I’m moving over from CentOS 7.

The missing modules are not unusual and will not affect the installer itself. Something else is holding up the installer from going any further but it is not clear what it is. You can try to edit the boot command line and remove “quiet” to see if it’ll give you a clue, but beyond that, it’s hard to say if there’s not anymore logs coming to your screen to indicate the issue.

Sometimes leaving it alone for a long enough will drop you to a dracut shell so you can look at the journal to maybe get a useful message to go off of too.

The BIOS shows “Quiet Boot [Enabled]”. Would this be equivalent to the boot command line you mention?

I’ll try leaving the installer hanging for longer and see if I can get into some logs.

I left the dead screen for an hour, and nothing. The screen has only the command line cursor, except it’s not blinking. Doesn’t respond to any inputs except power button, which shows “terminated” and then switches off. Disabling “quiet boot” made no difference.

I was able to run the Ubuntu installer. I stopped short of installation, but it was clearly running the installer GUI.

The only thing I’ve established is that my machine is in UIFE boot mode by default. I tried switching to legacy BIOS and got the same result. The BIOS offers me a UIFE shell as a boot option, but I wouldn’t know what to do with it.

If I can establish a fault with the machine then I’ll return it, but so far it smells like some compatibility issue with the installer. Clues welcome!