About win10 client

since the dead of centos7 I’ve thinked to move to rocky linux. Thus I’ve prepared a new server from scratch. As per centos7 I’ve done the same SMB server cfg to share data.
But, as all is working as expected with the old and good centos7, win10 pro is not able to connect to smb share , while, in the same network and same server my “Old” win7/64 connects with no trobules.
All knowed trick win10 side has been tryed (installed smb1 protocol, etc) but now way.
From SMB log side, there is no knock from w10 (either it pings the server).
very weird.
any1 experienced and has ideas how to solve ?

same with iptables on or off (linux side)
tried to manually mount the share in w10 ----> error 53
net use → error 64
smb1 protocol is on in the client ( Dism /online /Get-Features /format:table | find "SMB1Protocol")

First, centos7 is not “dead”. It should live to old age, to June 2024. The CentOS Linux 8 has EoL this year.

Second, RHEL8 is different from RHEL7. For one, there is no “iptables”; the kernel in 8 has nftables. The version of Samba is different too; config might require changes.

Centos8 Forum has threads about Samba. I never read those, but they might provide clues for you.

“dead” in the sense no more updated soon thus start new server with is waste of time and security


systemctl stop firewalld
systemctl mask firewalld
yum install iptables-services -y

works fine and well known

but win7/64 works fine. it’s just a win10 client issue… will investiagate furter ty.

Maybe it’s time to configure your samba server to use smbv2 or smbv3 even. Googling I found that people have the default samba config installed on CentOS 7, and Windows 7 and Windows 10 works fine. So perhaps you need to stop using smbv1. So if it works with the defaults on CentOS 7 then it should on Rocky since it’s newer as well. Maybe you copied/pasted your old config using smbv1, and this is why there is a problem.

CentOS Linux 7 will receive security updates and critical patches up to June 2024.
I did just start a server with 7. Took well under an hour, for I have configuration management.
I even contemplate skipping 8 for most production systems; why learn both 8 and 9?

The iptables.service is deprecated. The iptables tool is merely a wrapper for nft, and 100% complete translation is not possible.
The nftables.service is what Red Hat recommends (in RHEL 8) for those, who cannot use FirewallD. (That is, all serious use.)

tried also with minimal and maximal protocol… no luck

	passdb backend = tdbsam
	map to guest = Bad Password
	load printers = no
	default = temp
	printcap name = cups
	os level = 20
	security = user
	workgroup = WORKGROUP
	printing = cups
	cups options = raw
	ntlm auth = true
    protocol = SMB2
    client min protocol = SMB2
    client max protocol = SMB3

uh lemme reactivate win10 smb2/3…

sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
sc.exe config mrxsmb20 start= auto

nada :frowning: