9.2 Froze then No Wifi

I’ve resurrected a 10 year old desktop system and it has been running fine for a week. Today while composing an email it froze and I had to do a hard power off shutdown to get out of the freeze. On re-boot the WiFi Isn’t connecting and it’s icon is missing from the upper right corner of the login screen.

I went into the power menu and it is listed as “OFF.” I tried to turn it “ON” and then connect to a network and it doesn’t see any of the wireless networks around here. I tried to turn it on as a hotspot and did not see it’s signal with the WiFi spectrum analyzer app on my phone.

I’m thinking my D-Link DWA-525 PCI WiFi adapter has died. Any ideas or tips on how to start troubleshooting this would be greatly appreciated. Thank you, Dave

You could try looking in dmesg to see if there is any additional errors related to the WiFi card in there, especially as you try to force it on or activate it as a hotspot etc.

From your own detailed post, though, I think you likely have verified the problem – your WiFi card appears to have croaked! You’ve already performed most of the diagnostic steps I would have tried…

@LinuxGuy1997 - Thank you for responding to my post. I did look at the dmesg log and it didn’t flag any errors. I can see the boot system query the ieee80211 hardware and it responds. Then a bit later it loads the firmware and then queries the version to check the that it loaded. The next line after that (11 sec later ET) it did a resource sanity check: requesting [mem 0x000E0000-0x000FFFFF] which spans more than pnp 00:04 [mem 0x000E0000-0x000EFFFF]

I’m not sure what that means other than something (what?) wanted more memory than allowed.

So right after it boots to the desktop window it shows the power icon and the speakers icon but no WiFi fan icon. I open the menu and it offers a choice to turn the WiFi OFF. It is weird that there is no fan icon yet the OS thinks it is on. I’m going to re-install the driver next.

Meanwhile, I did buy another wifi card which I hope to have next week. Do you have any other thoughts about this?

Regards, Dave

Hi, @Odddave,

Many issues related to WiFi adapters suddenly not working usually are due to a kernel update which either breaks a previously-working kernel module that was necessary, or even causes a problem with an existing firmware file etc.

The fact that, in your particular situation, this happened while the system was up and running, and not after applying package updates via yum or dnf, plus the way the whole system froze unexpectedly… it still really sounds like a hardware issue to me. It’s curious that the device still shows up at all, but it’s obviously no longer functional, unfortunately.

I’m very much hoping that a replacement WiFi adapter fixes the problem for you. I also hope that you did some research and verified the replacement you ordered does have linux support; many WiFi adapters have proprietary firmware which only work reliably (if at all) on Windows, due to the chipset manufacturers not providing official support for the linux kernel… Some will provide drivers or kernel modules as “binary blobs” but these often only work with specific kernel versions, leading to them eventually becoming desktop paperweights when the vendor stops updating them.

Fingers crossed! :grinning:

1 Like

Hello, @LinuxGuy1997,

I found a new in box old stock exact replacement on eBay that should be here in Thursdays mail. Like you said, “fingers crossed.”

I really do appreciate your help on this. I’ll let you know how it turns out.


@LinuxGuy1997 - Success! I’m back or the internet! The way this behaved in that the card initialized properly as reported in dmesg it looks like the RF section died. I really appreciate your guidance with this problem. I’m very new to Linux and I had no idea dmesg existed. With every challenge I face building this system I learn a little more. Next up, connecting to the MyCloud NAS.

Again thanks,

1 Like

Excellent news, @Odddave ! Thanks for the update, and glad to hear it really was just a bad adapter.

You’re very welcome for whatever help I might have provided but, again, your detailed notes on what happened, how it happened, and all the steps taken afterwards was incredibly helpful as well! :grinning:

Linux might not be for everyone, and it’s not perfect, but I hope you’re able to continue to learn more about its various components, becoming that much more familiar with it, and enjoy it all the more, too.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.