Yum update cannot connect to update repos

Just did a vm install of Rocky Linux 8. All looks to be running fine. But I can’t do system update due to not finding Appstream repo. I see others with similar problems. Can’t go to the site mentioned. it appears down. See error message below:

Curl error (6): Couldn't resolve host name for https://mirrors.rockylinux.org/mirrorlist?arch=x86_64&repo=AppStream-8 [Could not resolve host: mirrors.rockylinux.org]

Can anyone diagnose whether the problem is with my system or with the repo site. I am new to this distro and don’t yet know my way around.
thanks, tom kosvic

I am able to resolve the URL. I would see if it’s an issue with your system configuration or network.

First Try to ping some IP like ping google public DNS like
ping 8.8.8.8
if you are getting response then your network connectivity to the internet is okay.

then you try to ping some URL like
ping nworks.in
if you are getting no response then in that your DNS server setting is not configured in your system, so you need to configure DNS first.

For setting up DNS use nmtui command and select your network interface card then select edit and here you can make DNS entry.
hope it will help.

Please share your response.

1 Like

What platform are you installing your VM on? Virtualbox? Did you set your network configurations correctly for your VM? Bridged Interface instead of NAT?

I am using libvirt (KVM). I am using the default network settings set up by vm manager. NAT is being used; not bridging. Bridging asks for a device name that I do not know. Installed libvirt device settings says virtio under the NAT setting.

I have 5 other linux’ setups as vms + windows10. All of these get internet and update fine. But I do think the problem is with the vm; not rocky linux. I will keep trying things.

thanks for ideas to check. tom kosvic

That runs ‘dnsmasq’ on the host that serves as both DHCP and DNS servers for the VM guests.
Furthermore, libvirt adds firewall rules into the host to allow traffic to be routed from VMs to outside (and back).

In the VM, what do you get with:

nmcli d s
nmcli c s
ip ro

(Plain nmcli shows most of that, but also unnecessary data.)

I have solved my rocky8 libvirt vm update/internet problem in a circuititous manner.
I deleted my rocky8 libvirt vm created from dvd iso.
I installed centos7 DVD iso as a libvirt vm using default libvirt network settings.
after install, centos7 connected to internat fine and allowed updates as have all the other linux’ I have as vms.
I installed elevate modules per internet instructions
Ran elevate that ultimately installed a large number of packages
Now rocky8 is fully functional as a libvirt vm with yum updates running using inital settings from centos7

I think now the problrm with libvirt vm installs now is within the dvd iso for rocky8.

tom kosvic

I do know that if one does CentOS 7 installation from local media, the installer creates connection definitions for NICs that it detects, but does not set them to start on boot, unless clicks “On/Off toggle”
in the installer. That, obviously can be changed after installation. The same installer, when doing network-based install, obviously has to have active connection during install and it sets those connections to start on boot.

For EL8 … I’ve done only PXE / network-based installs …

In other words, the “centos7 DVD iso install” on defaults gives “network off”. You did avoid that trap.

your response is very interesting but strange.
installing centos7 in libvirt produced a vm that was connected to wired lan after install. No manual steps. I was able to immediately update from it using yum.

installing rocky8 in a libvirt vm produced a vm that was NOT connected. It needed to be connected manually to lan. Even after manually connecting I could not get yum update to make a successful connection.

thus I went the route of upgrading centos to rocky using yum and elevate. Seems to be opposite of what your experience is.

thanks, tom kosvic

I can’t give up until I solve a problem.
I deleted rocky8 libvirt vm and started over. I reinstalled current download from website home rocky linux 8 again as a libvirt vm. Again, after install network was not connected. I manually connected. I could ping an ip address but nothing from dns worked. no webbrowser, no anything.

But, I rebooted my vm and it came back connected and all (including dns) worked. I got all the yum upgrades. Last time I did not reboot the system. I think all is well. (solved)

thanks all for your help. tom kosvic