Wine does not work in RL 9.2?

wine was available in the epel repository, so I went ahead and installed it (and heaps of dependencies) with

sudo dnf install wine

So now:

$ sudo dnf list wine
Installed Packages
wine.x86_64 8.0-1.el9 @epel
$ wine --version


$ wine notepad

0084:fixme:hid:handle_IRP_MN_QUERY_ID Unhandled type 00000005
0084:fixme:hid:handle_IRP_MN_QUERY_ID Unhandled type 00000005
0084:fixme:hid:handle_IRP_MN_QUERY_ID Unhandled type 00000005
0084:fixme:hid:handle_IRP_MN_QUERY_ID Unhandled type 00000005
0084:fixme:wineusb:query_id Unhandled ID query type 0x5.
0084:fixme:wineusb:query_id Unhandled ID query type 0x5.
0084:fixme:wineusb:query_id Unhandled ID query type 0x5.
00d4:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
00d4:err:winediag:nodrv_CreateWindow L"The explorer process failed to start."

What am I missing here? Are there comprehensive instructions somewhere how to correctly install and configure wine for Rocky Linux 9, preferably from a repository and not source?

Hello. You can check this.

Thanks, I was indeed missing this one:

$ sudo yum install wine-mono wine-gecko

but for some reason it is not working?

Last metadata expiration check: 0:01:41 ago on tis 13. juni 2023 14.52.12.
No match for argument: wine-mono
No match for argument: wine-gecko
Error: Unable to find a match: wine-mono wine-gecko

Those packages won’t exist, because the howto linked was for CentOS8, and since you are using EL9, then there are different package sets.

The problem isn’t here with Rocky, but rather with wine, googling:

00d4:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.

shows plenty of results, usually when it wasn’t run from a graphical environment/desktop that has or not been installed on the Linux machine itself, or some other reasons. I’m assuming you did install a desktop environment on your Rocky 9 install? Gnome? Something else?

Ok I thought the instructions were both for RHEL 8 and 9 as the title said " RHEL/CentOS Stream 9/8".

This is the desktop Rocky Linux 9.2 Gnome. Proprietary NVidia drivers have been installed and seem to be working with e.g. Steam (Team Fortress 2 and Portal 2 at least).

Yeah, I see that on the page, but the instructions just don’t fit. It’s almost like someone created it for EL8, and then figured it would just work for EL9 as well without actually re-writing the instructions or list of packages to install. EPEL9 doesn’t include the package listed in that howto.

And you ran:


without problems?

Maybe also try:

wine notepad.exe

Actually after just checking, none of the packages in the CentOS howto match what is in EPEL8 either. Let’s hope that winecfg runs, or perhaps by specifying .exe on the end of notepad will help out.

winecfg gives the same error, doesn’t work.
As does “wine notepad.exe”.

On some other forum some people are pretty sure some dependency is missing, but it might just as well be an educated guess.

I am just interested whether this works for anyone else? Ie. in Rocky Linux 9.2 (Gnome), install wine from the epel repository with “sudo dnf install wine”, does it work then? Ie. is the problem in my system, or a generic wine repository/dependency problem so it can’t work for any Rocky Linux 9.2 Gnome users?

I’ll let you know in about 30 mins, just gonna create a VM and see if I can replicate your problem or find a fix.

Hmm, well I have ran winecfg and notepad without problems, see attached screenshots:

I only had the minimal install ISO to hand, and as you see, from the left console window how I then installed the graphical environment and got it up and running. Although I doubt that is the problem. You can also see the command that I used to install wine. From the second console window I launched winecfg and notepad without problems.

On running winecfg it did say about needing a mono runtime, and I clicked the install button which then downloaded and installed it. Perhaps you are missing this? Maybe you can do from your home directory:

rm -rf .wine

and then instead of attempting to run notepad first, run winecfg first to ensure it prepares the environment properly. You can run it from the console window by just typing:


obviously do this as the same user that you are logged into Rocky as, not as root. My right console window where I launched winecfg/notepad was my normal user login name (not root).

rm -rf .wine

The first time I did that, winecfg window did appear! I clicked “Apply”, but after that winecfg nor wine notepad.exe would not launch, still the same error.

Even if I remove the .wine directory again, winecfg does not work again. I have no idea why winecfg did launch successfully once.

EDIT: Well this is odd. Sometimes winecfg works, sometimes not. Now I even managed to launch notepad once. I have no idea why it sometimes fails, and sometimes not.

I didn’t get that. What package is that and how can I install it manually?

Those RHEL8 instructions seemed to suggest installing that mono package, but that command didn’t work.

On another forum I was asked to run the command

$ sudo dnf provides '*ntdll*'

And based on the output I was told:

So the question is, why am I missing “the 32 bit package that provides syswow64/ntdll.dll”, and where can I get it? Is it that “mono” that my Linux didn’t ask to install, when running winecfg? and ntdll.dll comes in wine-core package - so if that package is installed you have it. The fact it ran fine on my system means, that the problem they mention might not be related to that. You can do however:

dnf install wine-core

just to be sure. I’ve done pretty much the same as you for installing wine, so you should have the same as me already installed. Since mine works, then the only thing I can think is that the mono thing that mine prompted me to download, which yours didn’t - is the source of the problem.

Under your home directory, do something like:

find ./ -iname *wine*

you are pretty much looking for any directories relating to wine configuration, usually .wine and perhaps others that might be somewhere else. Obviously be careful if you are unsure of what to delete, post the results from the above command, so we can check/verify what would be safe to remove.

Another alternative - create a new user on your system and then login as that user and run winecfg and see if it prompts for the mono package. If it does, then it means your own home directory for your current user has some config that is blocking that download because it may think it did it already.

sudo dnf install wine-core
Last metadata expiration check: 0:01:33 ago on ons 14. juni 2023 12.21.13.
Package wine-core-8.0-1.el9.x86_64 is already installed.
Dependencies resolved.
Nothing to do.

I also created a new user but it had the same problem, no mono installation was triggered either.

Worth to check this.

Guy wanted Wine up and running on Alma Linux machine, but the version that you get from dnf install wine only has 64-bit app support.

A majority of Windows apps are 32-bit, so this wasn’t going to work for him. So he figured to just compile Wine from source with 32-bit support…

Yeah, it’s really annoying that there is no 32-bit support in default package. I tried to compile wine from source to fix that and run 32-bit apps on my Rocky but… I found an interesting error while i was running ./config command. The x64 build was ok. Sadly, x32 config returned that there is no freetype 32-bit developement files and “Use the --without-freetype option if you really want this”. Funny, becasue I have installed (and reinstalled without effect) both x64 and i386 packages. x64 version config works and 32bit one not. Reinstallation of rpm (both x86_64 and i686) didn’t change anything. Moreover this thing happens with other wine versions, like 7.1, 8.1, 8.9 so probably it’s something wrong with package. I didn’t try compiling and installing x32 wine without fonts yet, so I cannot say much more. Get to know if you"ll try and how it will going on.

Yeah that is a good point, I didn’t realize there is a missing 32bit app support, and yes my WINE usage at this point is mostly for 32bit Windows programs, meaning older Windows games for the most part.

I presume I have some other issues as well, so I googled for something I seem to see quite often:

fixme:hid:handle_IRP_MN_QUERY_ID Unhandled type 00000005

I found e.g. this discussion:

and for some reason this suggestion seems to “work” for me:

Remove ~/.wine (if it exists). In terminal, run winecfg, this should open a window. Do nothing in it but leave it open. Open another terminal. Therein run wine clock and wine notepad or wine whatever, it should work.

So basically, if I am able to open the winecfg window (may take a few retries), as long as I keep that window open, I seem to have no issues starting e.g. wine notepad, wine explorer, wine clock…

I have no idea why keeping the winecfg window “fixes” the problem, and whether it fixes it completely. Very odd.

What is weird is that on my Rocky 9 I didn’t need to do that. I ran winecfg and closed it. I ran notepad and it opened fine. Not sure why yours is behaving differently TBH.