Warning:failed loading '/etc/yum.repos.d/remi.repo', skipping

Hello All,
after updating I got this error. I also cant remove VirtualBox (dont need it anymore).
What to do?

$ sudo dnf -y update
Warning: failed loading ‘/etc/yum.repos.d/remi.repo’, skipping.
Oracle Linux / RHEL / CentOS-8 / x86_64 - VirtualBox 9.1 kB/s | 819 B 00:00
Oracle Linux / RHEL / CentOS-8 / x86_64 - VirtualBox 7.6 kB/s | 1.7 kB 00:00
Oracle Linux / RHEL / CentOS-8 / x86_64 - VirtualBox 11 kB/s | 819 B 00:00
Error: Failed to download metadata for repo ‘virtualbox’: repomd.xml GPG signature verification error: Bad GPG signature

You can look at what that file has.

I almost always run dnf --enablerepo=* clean all
Sometimes it helps.

You can disable that repo with: dnf config-manager --disable virtualbox

it worked so far that the download went through and I can install other packages. But I would still gen the full functionality. And also to remove Virtualbox.

Thanks so far for the superfast hint.

Some other solutions would be nice!

Under /etc/yum.repos.d there will be files for the repositories installed on your system. One here possibly will be called virtualbox.repo ir similar. Just delete this file.

For removing virtualbox so that it’s no longer installed, assuming the package name is virtualbox, you would then do:

dnf remove virtualbox

If you are still having problems after this, please post your results so that we can see what is happening to be able to help further.

It’s usually something like VirtualBox-7 or similar. You might try

rpm -qa |grep -i VirtualBox

And see the result. If it’s something like VirtualBox-7.0.4 you can try

dnf remove VirtualBox-7

If it says no such package, then try 7.0 and so on.

If the package is from that “virtualbox” repo, then one could do:

dnf list installed | grep virtualbox

That should include both packages that have “virtualbox” in name, and packages that are from repo named “virtualbox”.

For what it’s worth, on my Rocky 8 system, VB is from the Oracle website, and and dnf list installed doesn’t work. rpm -qi VirtualBox-7.0 works.

As I think the OP got it from a rocky repo, that should affect them, putting that info here though, in case someone’s web search brings them to this thread.

1 Like

Hi scottro,

virtualbox is deleted, … thanks so far …

but if I run $ sudo dnf update

I still have the error:

Warning: failed loading ‘/etc/yum.repos.d/remi.repo’, skipping

guess remi.repo has it’s reason. So it should load. Or?


I did suggest you to look at that file. What does it have?

Oh, sorry. I did not understand to tell you the result.

$ rpm -qa | grep -i VirtualBox

The message is not about VirtualBox. It is about file:

PS. You do have VirtualBox installed.

Ok, nice. Hopefully starting to learn something.

rpm -qa

query’s all files of the “whole” package-manager

grep limit`s its query to VirtualBox

, and with the full Name of the file

$ sudo dnf remove VirtualBox-6.1.x86_64

it does the job to remove VirtualBox.

But while upadating, still

Warning:failed loading ‘/etc/yum.repos.d/remi.repo’, skipping

Just to understand:

The two errors
----> Warning:failed loading ‘/etc/yum.repos.d/remi.repo’, skipping
—> Error: Failed to download metadata for repo ‘virtualbox’: repomd.xml GPG signature verification error: Bad GPG signature

are not-at least not direct-related to each other?

Anyway, the Warning (as the title of the article) still exists.

How to diagnose and cure it?


The remi.repo is not loading, maybe due to bad formatting or invalid characters. If you are not using packages from this, move the file to a different directory so that dnf/yum doesn’t load it. Do the same for the virtualbox repo file, since if you uninstalled, you no longer want to use it. That will also solve the bad gpg error, since dnf/yum will no longer use it.

You can also edit the repo files, and just change enabled=1 to enabled=0. Although that will unlikely work if the file is incorrectly formatted. We would need to see the content of the file to be able to say for sure.

Before I try to do as you recommend I just want to ask, how I can know what kind of packages are “packed” by that specific repo, so to know if I need them in future or not?

Neither “virtualbox” nor “remi” repo definitions are provided by Rocky. You got those definitions from somewhere, so you can get them again, if needed.

Remi’s repositories are described in Rocky Linux Repositories - Rocky Linux Wiki

The “virtualbox” most likely provides VirtualBox. Was it this: Linux_Downloads – Oracle VM VirtualBox

Thank you very much!

You can use this command:

dnf list installed

it will show against each package installed from which repository it came from. Obviously it lists all packages installed, but you can use that to grep for remi or virtualbox - the names of the two you wanted to disable to see if anything got left behind and not removed.

There will be exceptions to that rule if an rpm was installed outside of dnf/yum repositories for example. For example I make my own rpm for installing pycharm community on my system, and it shows @System instead of a named repository.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.