Trying to Install Teradici PCOIP Client On Rocky 8.9

Hello, I’ve been trying to install the Teradici PCOIP Client on Rocky. There is only a Ubuntu / deb installer on the website, however someone in a previous post mentioned that it was in beta for RHEL.

I tried this:

curl -1sLf https://dl.anyware.hp.com/vUJtPyh2fJdAXVJZ/pcoip-client-beta/cfg/setup/bash.rpm.sh | sudo -E distro=el codename=9 bash
sudo dnf install pcoip-client

The curl is successful but where I run into issues is with the install.

This is the error I am receiving in terminal:

Error:
Problem: cannot install the best candidate for the job

  • nothing provides libc.so.6(GLIBC_2.34)(64bit) needed by pcoip-client-23.08.1-1.el9.x86_64 from teradici-pcoip-client-beta
  • nothing provides libhiredis.so.1.0.0()(64bit) needed by pcoip-client-23.08.1-1.el9.x86_64 from teradici-pcoip-client-beta
  • nothing provides libm.so.6(GLIBC_2.29)(64bit) needed by pcoip-client-23.08.1-1.el9.x86_64 from teradici-pcoip-client-beta
  • nothing provides libstdc++.so.6(CXXABI_1.3.13)(64bit) needed by pcoip-client-23.08.1-1.el9.x86_64 from teradici-pcoip-client-beta
  • nothing provides libstdc++.so.6(GLIBCXX_3.4.26)(64bit) needed by pcoip-client-23.08.1-1.el9.x86_64 from teradici-pcoip-client-beta
  • nothing provides libstdc++.so.6(GLIBCXX_3.4.29)(64bit) needed by pcoip-client-23.08.1-1.el9.x86_64 from teradici-pcoip-client-beta
    (try to add ‘–skip-broken’ to skip uninstallable packages or ‘–nobest’ to use not only best candidate packages)

I tried it on Rocky 9.3 as well. Has anyone had any luck with this?

Much appreciated for any help!

My workaround for now is using boxes, installing Ubuntu and then installing Teradici. It does work, but not ideal.

Did something disable your default repositories (baseos, appstream, maybe crb)? It appears that you have some repositories disabled, which is leading to most if not all of those errors.

I don’t believe so, at least not intentionally. I installed flatpaks and snaps but that’s the only thing out of the box. How would I enable them?

But you should get a different error on 9.3? glibc 2.34 should exist on 9.3

The rpm says ‘el9’ not ‘el8’ so was the output above from 8.9 or 9.3?

The bash.rpm.sh script does have a line where they disable all repos (but only for making the cache). Check the whole of bash.rpm.sh in case they make a mistake.

Try also

dnf repolist all

The output above was from 8.9

This is the list I get:

repo id repo name status
appstream Rocky Linux 8 - AppStream enabled
appstream-debuginfo Rocky Linux 8 - AppStream - Source disabled
appstream-source Rocky Linux 8 - AppStream - Source disabled
baseos Rocky Linux 8 - BaseOS enabled
baseos-debuginfo Rocky Linux 8 - BaseOS - Source disabled
baseos-source Rocky Linux 8 - BaseOS - Source disabled
devel Rocky Linux 8 - Devel WARNING! FOR BU disabled
epel Extra Packages for Enterprise Linux 8 enabled
epel-debuginfo Extra Packages for Enterprise Linux 8 disabled
epel-modular Extra Packages for Enterprise Linux M disabled
epel-modular-debuginfo Extra Packages for Enterprise Linux M disabled
epel-modular-source Extra Packages for Enterprise Linux M disabled
epel-source Extra Packages for Enterprise Linux 8 disabled
epel-testing Extra Packages for Enterprise Linux 8 disabled
epel-testing-debuginfo Extra Packages for Enterprise Linux 8 disabled
epel-testing-modular Extra Packages for Enterprise Linux M disabled
epel-testing-modular-debuginfo Extra Packages for Enterprise Linux M disabled
epel-testing-modular-source Extra Packages for Enterprise Linux M disabled
epel-testing-source Extra Packages for Enterprise Linux 8 disabled
extras Rocky Linux 8 - Extras enabled
google-chrome google-chrome enabled
ha Rocky Linux 8 - HighAvailability disabled
ha-debuginfo Rocky Linux 8 - High Availability - S disabled
ha-source Rocky Linux 8 - High Availability - S disabled
media-appstream Rocky Linux 8 - Media - AppStream disabled
media-baseos Rocky Linux 8 - Media - BaseOS disabled
nfv Rocky Linux 8 - NFV disabled
plus Rocky Linux 8 - Plus disabled
powertools Rocky Linux 8 - PowerTools disabled
powertools-debuginfo Rocky Linux 8 - PowerTools - Source disabled
powertools-source Rocky Linux 8 - PowerTools - Source disabled
resilient-storage Rocky Linux 8 - ResilientStorage disabled
resilient-storage-debuginfo Rocky Linux 8 - Resilient Storage - S disabled
resilient-storage-source Rocky Linux 8 - Resilient Storage - S disabled
rt Rocky Linux 8 - Realtime disabled
teradici-pcoip-client-beta teradici-pcoip-client-beta enabled
teradici-pcoip-client-beta-noarch teradici-pcoip-client-beta-noarch enabled
teradici-pcoip-client-beta-source teradici-pcoip-client-beta-source enabled

Thank you for your help!

Running the bash.rpm.sh command with codename=9 will set things up for el9 not el8 …

You should remove /etc/yum.repos.d/teradici-pcoip-client-beta.repo file and run the following instead:

curl -1sLf https://dl.anyware.hp.com/xrXsyLJMLVPnQ7L0/pcoip-client-beta/cfg/setup/bash.rpm.sh | sudo -E distro=el codename=8 bash

That should create a suitable repo file for Rocky 8 (el8)

For Rocky 9 (el9), use the above, but with codename=9

amazing that worked! thank you!