Systemd Redhat autostart after reboot service does not actually start program DropServer

Hoping someone somewhere understand systemd enough to help me with a bug. I can’t seem to get an autostart to work. Not in Rocky but in RHEL

Hi there :slight_smile:

What does systemctl status <systemd-service-name> say?

Because this also tells you if the autostart is enabled for a service, like:

$ systemctl status auditd
● auditd.service - Security Auditing Service
     Loaded: loaded (/usr/lib/systemd/system/auditd.service; enabled; preset: enabled)

the 1st enabled tells the actual autostart state, the 2nd one what the system has a default.

The services that come with rocky will autostart when the service is “enabled”. e.g. as root
systemctl is-enabled auditd.service
but what is drop server, is does it come with rocky?

Nothing listed here regarding setup for systemd.

It’s here: Dropserver Personal Application Server

And I also already see the issue, it only mentions systemctl start dropserver but not systemctl enable dropserver (or even combined systemctl enable --now dropserver)