Slurm does not install from the epel repo

I am running Rocky 8.3 and trying to install slurm on my CtlIQ warewulf headnode. The only slurm I could find in a repo was in the epel repo. When I try to install it, it appears one of the dependenies is missing. libsz.so.2

dnf install slurm.x86_64

Last metadata expiration check: 0:07:20 ago on Wed 02 Jun 2021 05:26:13 PM PDT.
Error:
Problem: conflicting requests

  • nothing provides libsz.so.2()(64bit) needed by slurm-20.11.6-1.el8.x86_64
    (try to add ‘–skip-broken’ to skip uninstallable packages or ‘–nobest’ to use not only best candidate packages)

looks like you have to enable the powertools repo

Success ! that did the trick. Thanks.